C - Edge (HDU 1033)

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.
You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

输入样例的示意图

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

题解

题意&思路:

  • 可以想象为一条曲折的马路。起点在(300,400)的位置,马路延伸到(300,420)的位置,然后向右延伸到(310,420)的位置。之后根据输入的A或V,以及前一次延伸的方向(上、下、左、右),来确定延伸的方向,每次延伸10个单位长度。
  • 记当前位置为(x,y),记前一次延伸对应的向量(det_x,det_y)为:上(0,10)、下(0,-10)、左(-10,0)、右(10,0)。
  • 每次以(det_x,det_y)为参考,确定顺时针或逆时针的延伸方向,并更新(x,y)和(det_x,det_y)。
  • 300 420 moveto
    310 420 lineto
    为固定输出
    之后每延伸一次就输出一次x y lineto
    末尾再输出
    stroke
    showpage
(det_x,det_y)V(逆时针)A(顺时针)
上(0,10)
下(0,-10)
左(-10,0)
右(10,0)

Code

#include<iostream>
#include<string>
#include<cstring>

using namespace std;

int main()
{
    char ch[205];
    int x, y, det_x, det_y, len;
    while(cin >> ch)
    {
        len = strlen(ch);//包含VA的字符串的长度
        x = 310;//因为前两步时固定的,所以起始位置就设为(310,420)
        y = 420;
        det_x = 10;
        det_y = 0;
        cout << "300 420 moveto" << endl;
        cout << "310 420 lineto" << endl;
        for(int i = 0;i < len; i++)
        {
            if(ch[i] == 'V')
            {
                if(det_x == 0)
                {
                    if(det_y == 10)
                    {
                        x -= 10;
                        det_x = -10;
                        det_y = 0;
                    }
                    else
                    {
                        x += 10;
                        det_x = 10;
                        det_y = 0;
                    }                  
                }
                else
                {
                    if(det_x == 10)
                    {
                        y += 10;
                        det_y = 10;
                        det_x = 0;
                    }
                    else
                    {
                        y -= 10;
                        det_y = -10;
                        det_x = 0;
                    }
                }
            }
            else if(ch[i] == 'A')
            {
                if(det_x == 0)
                {
                    if(det_y == -10)
                    {
                        x -= 10;
                        det_x = -10;
                        det_y = 0;
                    }
                    else
                    {
                        x += 10;
                        det_x = 10;
                        det_y = 0;
                    }                   
                }
                else
                {
                    if(det_x == -10)
                    {
                        y += 10;
                        det_y = 10;
                        det_x = 0;
                    }
                    else
                    {
                        y -= 10;
                        det_y = -10;
                        det_x = 0;
                    }
                }
            }
            cout << x <<' '<< y <<' '<< "lineto" << endl; 
        }
        cout << "stroke" << endl;
        cout << "showpage" << endl;
    }
    
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值