R - Joseph(POJ 1012)

Description

The Joseph’s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
3
4
0
Sample Output
5
30
题解

题意:

  • 有k个好人和k个坏人,好人为前k个。从第一个好人开始报数,报到m的人将被KILL,然后从下一个开始重新报数。要求好人将被KILL前,所有坏人已经被KILL了,求满足条件的m。

思路:

  • k比较小,枚举m
  • 递推式:pi = (pi-1 + m-1) % (n - (i-1));pi为第i轮被选人的编号
Code
#include<iostream>
using namespace std;

int Joseph[14]={0}, people[30]={0};
//前者用于存m,后者用于存每一轮被杀的人的编号,编号从0开始
int k, n, m;

int main()
{
	while(cin>>k && k)
	{
		if(Joseph[k])
		{
			cout<<Joseph[k]<<endl;
			continue;
		}
		n = 2 * k;
		m = k + 1;		//m肯定大于k,不然第一个死的是好人
		for(int i = 1; i <= k; i++)
		{
			people[i]=(people[i-1]+m-1)%(n-i+1); 
			//上一轮被杀者编号加上m-1,对上一轮剩下的人数取模,得到本轮选出的人编号
			//因为每一轮都从上一个被选的人的下一位开始编号,且以0为第一个编号,所以上面是加m-1
            if(people[i]<k)                       
			{
				i = 0;
				m++; 
			}
		}
		Joseph[k] = m;
		cout<<m<<endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值