Circular Sequence(思维)

Some DNA sequences exist in circular forms as in the following figure, which shows a circular sequence “CGAGTCAGCT”, that is, the last symbol “T” in “CGAGTCAGCT” is connected to the first symbol “C”. We always read a circular sequence in the clockwise direction. Since it is not easy to store a circular sequence in a computer as it is, we decided to store it as a linear sequence. However, there can be many linear sequences that are obtained from a circular sequence by cutting any place of the circular sequence. Hence, we also decided to store the linear sequence that is lexicographically smallest among all linear sequences that can be obtained from a circular sequence. Your task is to find the lexicographically smallest sequence from a given circular sequence. For the example in the figure, the lexicographically smallest sequence is “AGCTCGAGTC”. If there are two or more linear sequences that are lexicographically smallest, you are to find any one of them (in fact, they are the same).

Input
The input consists of T test cases. The number of test cases T is given on the first line of the input file. Each test case takes one line containing a circular sequence that is written as an arbitrary linear sequence. Since the circular sequences are DNA sequences, only four symbols, ‘A’, ‘C’, ‘G’ and ‘T’, are allowed. Each sequence has length at least 2 and at most 100.

Output
Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence for the test case.

Sample Input
2 CGAGTCAGCT CTCC

Sample Output
AGCTCGAGTC CCCT

在这里插入图片描述

题意:给你一组字符串,像上图一样,任意首尾都可以相连,让你找出从哪开头可以使字符串的字典序最小,输出这个字符串。

思路:(我不知道是不是有更好的办法,因为我这个用了两个sort,虽然没超时,但数据范围要是更大就不确定了。),我的思路就是先找出数组中字符最小的那个,然后遍历数组,找到最小的字符后,把此位置前面的接到后面去,存在字符串数组中,遍历完排个序,输出最小的即可。

代码:

#include<bits/stdc++.h>
using namespace std;
string a,c[110];
char b;
int n,m[110],k;
int main()
{
 cin>>n;
 while(n--)
 {
  b='Z';
  k=0;
  memset(m,0,sizeof(m));
  cin>>a;
  for(int i=0;i<a.size();i++)
  {
   if(a[i]<b) b=a[i];
  }
  for(int i=0;i<a.size();i++)
  {
   if(a[i]==b)
   {
    c[k]=a.substr(i,a.size());
    c[k]+=a.substr(0,i);
    k++;
   }
  }
  sort(c,c+k);
  cout<<c[0]<<endl;
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值