二叉排序树

Problem Description

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树
Input

开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)
Output

Sample Input

2
123456789
987654321
432156789
0
Sample Output

NO
NO

#include<bits/stdc++.h>
using namespace std;
const int maxx=111;
struct node
{
    int data;
    node*l,*r;
};

node*insertt(node*root,int x)
{
    if(root==NULL)
    {
        root=new node();
        root->data=x;
        root->l=NULL;
        root->r=NULL;
    }
    else
    {
        if(x>root->data)
            root->r=insertt(root->r,x);
        else
            root->l=insertt(root->l,x);
    }
    return root;
}

//用前序、中序、后序都是可以的
int flag=0;
void mid(node*root,node*root1)
{
    if(root&&root1)
    {        
        mid(root->l,root1->l);
        if(root->data!=root1->data)
        {
            flag=1;
            return;
        }
        mid(root->r,root1->r);
    }
}

int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)
            break;
        else
        {
            char q1[maxx],q2[maxx];
            cin>>q1;
            node*root=new node();
            root=NULL;
            int len1=strlen(q1);
            for(int i=0; i<len1; i++)
                root=insertt(root,int(q1[i]));
            while(n--)
            {
                node*root1=new node();
               root1=NULL;
                cin>>q2;
                int len2=strlen(q2);
                for(int i=0; i<len2; i++)
                    root1=insertt(root1,int(q2[i]));
                mid(root,root1);
                if(flag==0)
                    cout<<"YES"<<endl;
                else
                    cout<<"NO"<<endl;
                flag=0;
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值