M - Sekiro

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying gg amount of money, the amount of money will be reduced to \left\lceil \frac{g}{2} \right\rceil⌈
2
g

⌉, where \left\lceil \frac{g}{2} \right\rceil⌈
2
g

⌉ indicates the smallest integer g’g

that 2g’ \ge g2g

≥g.

As a noobie of the game, BaoBao has died kk times in the game continuously. Given that BaoBao carried nn amount of money before his first death, and that BaoBao didn’t collect or spend any money during these kk deaths, what’s the amount of money left after his kk deaths?

Input
There are multiple test cases. The first line of the input contains an integer TT (about 10^310
3
), indicating the number of test cases. For each test case:

The first and only line contains two integers nn and kk (0 \le n \le 10^90≤n≤10
9
, 1 \le k \le 10^91≤k≤10
9
), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output
For each test case output one line containing one integer, indicating the amount of money left after kk deaths.

Sample Input
4
10 1
7 1
10 2
7 2
Sample Output
5
4
3
2
Hint
For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.
注意:如果n=1或者0的时候,就要退出循环,因为1/2再向上取整,一直为1
一直对n/2,如果是奇数就是n/2+1,如果是偶数则为n/2

#include<bits/stdc++.h>
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        int n,k;
        cin>>n>>k;
        while(k)
        {
            if(n%2==0)
                n=n/2;
            else
                n=n/2+1;
            if(n==1||n==0)
                break;
            k--;
        }
        cout<<n<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值