回溯3 素数环

A ring is compose of n circles as shown in diagram. Put natural number
1, 2, …, n into each circle separately, and the sum of numbers in
two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a
series of circle numbers in the ring beginning from 1 clockwisely and
anticlockwisely. The order of numbers must satisfy the above
requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case. Sample Input 6 8 Sample 、

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意就是有一个环,相邻的两个数加起来要是素数。第一个固定是1

思路就是创建两个数组,一个用来保存环,一个用来判断每个数有没有重复利用。然后写一个判断素数函数和一个dfs。

#include<iostream>

using namespace std;

int arr[21];
bool bl[21];
int n;

bool isprime(int a)
{
	for(int i=2;i<=a/2;i++)
	{
		if(!(a%i)) return false;
	}
	
	return true; 
}

void dfs(int a)
{
	if(a>n&&isprime(arr[n]+arr[1]))
	{
		 cout<<"1";
		for(int i=2;i<=n;i++)
		cout<<" "<<arr[i];
		cout<<endl;
		return ; 
	}
	
	for(int i=2;i<=n;i++)
	{
		arr[a]=i;
		if(bl[i]&&isprime(arr[a]+arr[a-1]))
		{
			bl[i]=false;
			dfs(a+1);
			bl[i]=true;
		  }  
	}
}

int main(){
	int k=1;
	while(cin>>n)
	{
		
    	arr[1]=1;
	    for(int i=1;i<=n;i++)
	    bl[i]=true;
	    bl[1]=false;
	    cout<<"Case "<<k<<":"<<endl;
	    dfs(2); 
	    cout<<endl;
	    k++;
	    
	}

	
	
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值