Pots(bfs,记录路径)

Pots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27405 Accepted: 11494 Special Judge
Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4
Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
Source

Northeastern Europe 2002, Western Subregion

bfs,dfs不仅可以记录路径还可以记录状态
这题就记录的两个罐子装水的状态

#include <stdio.h>
#include <memory.h>
#include <string.h>
#include <algorithm>
#include <queue>
#define INF 0x3f3f3f3f
#define ll long long
using namespace std;
struct node
{
    int a,b,c,num;
}p[101][101];//结构体里p[x][y] x,y记录当前状态,.a .b记录前一步状态
int vis[101][101];
void dfs(int x,int y)
{
    if(x==0&&y==0)
        return ;
    dfs(p[x][y].a,p[x][y].b);
    if(p[x][y].c==0)
        printf("FILL(1)\n");
    if(p[x][y].c==1)
        printf("FILL(2)\n");
    if(p[x][y].c==2)
        printf("DROP(1)\n");
    if(p[x][y].c==3)
        printf("DROP(2)\n");
        if(p[x][y].c==4)
        printf("POUR(1,2)\n");
    if(p[x][y].c==5)
        printf("POUR(2,1)\n");
        return ;
}
void bfs(int a,int b,int c)
{
    int i,x;
    queue<node>quee;
    memset(vis,0,sizeof(vis));
    struct node t,now;
    t.a=0;t.b=0;t.num=0;
    vis[0][0]=1;
    quee.push(t);
    while(!quee.empty())
    {
        now=quee.front();
        quee.pop();
        if(now.a==c||now.b==c)
        {
            printf("%d\n",now.num);
            dfs(now.a,now.b);
            return ;
        }
        for(i=0;i<6;i++)
        {
            if(i==0)
            {
                t.a=a;t.b=now.b;
            }
            if(i==1)
            {
                t.a=now.a;t.b=b;
            }
            if(i==2)
            {
                t.a=0;t.b=now.b;
            }
            if(i==3)
            {
                t.a=now.a;t.b=0;
            }
            if(i==4)
            {
                x=now.a+now.b;
                if(x>b)
                {
                    t.b=b;t.a=x-b;
                }
                else
                {
                    t.b=x;t.a=0;
                }
            }
            if(i==5)
            {
                x=now.a+now.b;
                if(x>a)
                {
                    t.a=a;t.b=x-a;
                }
                else
                {
                    t.a=x;t.b=0;
                }
            }
            if(t.a<0||t.a>a||t.b<0||t.b>b)
            {
                continue;
            }
            if(!vis[t.a][t.b])
            {
                vis[t.a][t.b]=1;
                t.num=now.num+1;
                quee.push(t);
                p[t.a][t.b].a=now.a;//记住上一次罐子状态
                p[t.a][t.b].b=now.b;
                p[t.a][t.b].c=i;   //记住本次操作
            }
        }
    }
    printf("impossible\n");
}
int main()
{
    int a,b,c;
    scanf("%d%d%d",&a,&b,&c);
    bfs(a,b,c);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值