SDUT-3346-数据结构实验之二叉树七:叶子问题

Problem Description

已知一个按先序输入的字符序列,如abd,eg,cf,(其中,表示空结点)。请建立该二叉树并按从上到下从左到右的顺序输出该二叉树的所有叶子结点。
Input
输入数据有多行,每一行是一个长度小于50个字符的字符串。
Output
按从上到下从左到右的顺序输出二叉树的叶子结点。
Sample Input

abd,eg,cf,
xnl,i,u,

Sample Output

dfg
uli

Hint

Source
xam

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct tree
{
    struct tree *left,*right;
    char data;
};
char a[55];
int i;
struct tree * creat()
{
    if(a[i]==',')
    {
        i++;
        return NULL;
    }
    struct tree *t;
    t=(struct tree *)malloc(sizeof(struct tree));
    t->data=a[i];
    i++;
    t->left=creat();
    t->right=creat();
    return t;
}

void arrangeshow(struct tree *t)
{
    struct tree *treenode[55];
    int in=0,out=0;
    treenode[in++]=t;
    while(in>out)
    {
        if(treenode[out]!=NULL)
        {
            treenode[in++]=treenode[out]->left;
            treenode[in++]=treenode[out]->right;
            if(treenode[out]->left==NULL&&treenode[out]->right==NULL)
                printf("%c",treenode[out]->data);
        }
        out++;
    }
}

int main()
{
    struct tree *root;
    while(~scanf("%s",a))
    {
        i=0;
        root=creat();
        arrangeshow(root);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值