Play the Dice——(数学)

There is a dice with n sides, which are numbered from 1,2,…,n and have the equal possibility to show up when one rolls a dice. Each side has an integer ai on it. Now here is a game that you can roll this dice once, if the i-th side is up, you will get ai yuan. What’s more, some sids of this dice are colored with a special different color. If you turn this side up, you will get once more chance to roll the dice. When you roll the dice for the second time, you still have the opportunity to win money and rolling chance. Now you need to calculate the expectations of money that we get after playing the game once.

Input

Input consists of multiple cases. Each case includes two lines.
The first line is an integer n (2<=n<=200), following with n integers a i(0<=a i<200)
The second line is an integer m (0<=m<=n), following with m integers b i(1<=b i<=n), which are the numbers of the special sides to get another more chance.

Output

Just a real number which is the expectations of the money one can get, rounded to exact two digits. If you can get unlimited money, print inf.

Sample Input

6 1 2 3 4 5 6
0
4 0 0 0 0
1 3

Sample Output

3.50
0.00

/* HDU - 4586 */

题意

给你一个n个面的骰子,然后每个面上都有特定的值,你有一次机会抛骰子,你可以获得朝上那面的值的分数。n面骰子 中有m面是特殊的面,当你抛到这些特殊的面的时候,你可以再抛一次骰子。问你最后获得分数的期望是多少。ps 抛到每一面的机会都是相等的。

思路

如果所有面的分数之和为sum,我们可以知道,每一次的得分期望是sum/n,并且每一次抛到特殊面的概率为m/n,这样我们就得到了他们的概率,1+m/n+(m/n)^2+(m/n) ^t;t趋向于正无穷。这样这个问题就转换成了求上述无穷级数的收敛值的问题。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<map>
#include<ctime>
#include<vector>
#include<cstring>
#include<iomanip>
using namespace std;
int main()
{
    int n,m,sum,k;
    while (cin>>n)
    {
        sum = 0;
        for (int i = 0; i < n; i++)
        {
            cin>>k;
            sum += k;
        }
        cin>>m;
        for (int i = 0; i < m; i++)
        cin>>k;
        if (sum == 0)
        {
            puts("0.00");
            continue;
        }
        if (m >= n)
        {
            puts("inf");
        }
        else
            printf("%.2f\n", 1.0 * sum / (n - m));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值