The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

思路:本题题意就是有n个学生,m个社团,若干学生参加二社团,现在标号为0的学生具有传染病,在这一个社团的学生都有可能被传染,求可能被传染的人数使用并查集把和0有直接和间接接触的学生给放在一个集合中,求出这个集合中的人数即可。特殊处理就是使用一个数组来表示每个人所在集合以及与其有着一定关联的人数,初始都只是自己一个本身,经过并查集的使用将他们合成一个集合,这里主要就是寻找父节点的过程中进行一下数量的不断添加。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int f[30020],num[30020];
void init()
{
    for(int i=0;i<n;i++)
    {
        f[i]=i;
        num[i]=1;初始化每个点都是以自己为父节点和自己本身一个点
    }
}
int get(int x)//找父节点的过程
{
    if(f[x]==x)
        return x;
    else
    {
        f[x]=get(f[x]);
        return f[x];
    }
}
void merge(int u,int v)
{
    int t1=get(u);
    int t2=get(v);
    if(t1!=t2)
    {
        f[t1]=t2;
        num[t2]+=num[t1];//这里主要记录两个点集合在一起。
    }
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        init();
        for(int i=0;i<m;i++)
        {
            int t,u,v;
            scanf("%d %d",&t,&u);
            for(int j=1;j<t;j++)
            {
                scanf("%d",&v);
                merge(u,v);
            }
        }
        int x=get(0);//这里就是找关于0的父节点。其实就是包含0这个的集合的父节点。
        printf("%d\n",num[x]);//得到这个父节点为首的集合有多少个子孙节点就是题中可能被感染的人数。
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值