KMP:Count the string HDU - 3336 Simpsons’ Hidden Talents HDU - 2594

Count the string

HDU - 3336

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab

Sample Output

6

题意与解析:

给一个字符串求其从头到尾的前缀出现的次数之和。

next数组的值就是记录当前位置向前多少个和这个字符串开头多少个相等,有了这样我们只要记录每个next这对应有多少个,然后加上n个自身的一个匹配就行了。 

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include <cstdlib>
#include<algorithm>
using namespace std;
char b[200020];
int book[200020];
int nex[200020];
int t,n,m;
void get()///kmp模板
{
    int i=0,j=-1;
    nex[0]=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            i++;
            j++;
            nex[i]=j;
        }
        else
            j=nex[j];
    }
}
int main()
{
    cin>>t;
    while(t--)
    {
        memset(book,0,sizeof(book));
        cin>>m>>b;
        get();
        int ans=m;
        for(int i=1;i<=m;++i)//计算每一个前缀出现的次数,用book数组进行记录
            book[nex[i]]++;
        for(int i=1;i<=m;++i)///求和并且取模
            ans=(ans+book[i]%10007)%10007;
        cout<<ans<<endl;
    }
    return 0;
}

 

Simpsons’ Hidden Talents

HDU - 2594

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

题意与解析:

给两个字符串求其前缀与后缀最大长度相同字符串,输出相同字符串的长度以及输出求得的相同字符串;

利用kmp的nex数组可得到;

代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[50020],s2[50020];
int nex[50020];
void kmp()///kmp模板
{
    int i=0,j=-1;
    int l=strlen(s1);
    nex[0]=-1;
    while(i<l)
    {
        if(j==-1||s1[i]==s1[j])
            nex[++i]=++j;
        else
            j=nex[j];
    }
}
int solve()//利用nex数组进行比较即可
{
    int i=0,j=0;
    int l1=strlen(s1),l2=strlen(s2);
    while(i<l2)
    {
        if(j==-1||s1[j]==s2[i])
        {
            i++;
            j++;
            if(j==l1&&i!=l2)
                j=nex[j];
        }
        else
            j=nex[j];
    }
    return j;
}
int main()
{
    while(gets(s1)>0)
    {
        gets(s2);
        kmp();
        int ans=solve();
        s1[ans]='\0';
        if(ans!=0)
            printf("%s %d\n",s1,ans);
        else
            printf("0\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值