POJ - 2289 Jamie's Contact Groups(二分+二分图多重匹配)

Jamie’s Contact Groups
Jamie is a very popular girl and has quite a lot of friends, so she always keeps a very long contact list in her cell phone. The contact list has become so long that it often takes a long time for her to browse through the whole list to find a friend’s number. As Jamie’s best friend and a programming genius, you suggest that she group the contact list and minimize the size of the largest group, so that it will be easier for her to search for a friend’s number among the groups. Jamie takes your advice and gives you her entire contact list containing her friends’ names, the number of groups she wishes to have and what groups every friend could belong to. Your task is to write a program that takes the list and organizes it into groups such that each friend appears in only one of those groups and the size of the largest group is minimized.
Input
There will be at most 20 test cases. Ease case starts with a line containing two integers N and M. where N is the length of the contact list and M is the number of groups. N lines then follow. Each line contains a friend’s name and the groups the friend could belong to. You can assume N is no more than 1000 and M is no more than 500. The names will contain alphabet letters only and will be no longer than 15 characters. No two friends have the same name. The group label is an integer between 0 and M - 1. After the last test case, there is a single line `0 0’ that terminates the input.
Output
For each test case, output a line containing a single integer, the size of the largest contact group.

Sample Input
3 2
John 0 1
Rose 1
Mary 1
5 4
ACM 1 2 3
ICPC 0 1
Asian 0 2 3
Regional 1 2
ShangHai 0 2
0 0

Sample Output
2
2

题意:一个人有很多联系人,但是不方便管理,所以他想把这些联系人分成组,已知这些联系人可以被分到哪个组中去,而且要求每个组的联系人上限最小,即有一整数k,使每个组的联系人数都不大于k,问这个k最小是多少?

思路:看完题目其实很简单就可以想到二分,但是还涉及到匹配的问题,这还是我做的第一道二分图多重匹配的题目,其实多重匹配就是在匈牙利算法的基础上加限制条件,比如说这道题加的限制条件就是每个组的联系人个数都不能超过k,所以在这道题里就可以用二分求出这个limit,直到找出那个能构成多重匹配的最小的limit。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<iostream>
#include<algorithm>
using namespace std;

#define maxn 1100
#define ll long long
#define inf 0x3f3f3f3f
#define mod 998244353

struct node
{
    int sum;
    int v[maxn];
}a[maxn];

int n,m;
int mp[maxn][maxn],vis[maxn];

int dfs(int u,int limit)
{
    for(int i=1;i<=m;i++)
    {
        if(mp[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(a[i].sum<limit)
            {
                a[i].v[a[i].sum++]=u;
                return 1;
            }
            else
            {
                for(int j=0;j<a[i].sum;j++)
                {
                    if(dfs(a[i].v[j],limit))
                    {
                        a[i].v[j]=u;
                        return 1;
                    }
                }
            }
        }
    }
    return 0;
}

int hungary(int limit)
{
    memset(a,0,sizeof(a));
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(!dfs(i,limit))
            return 0;
    }
    return 1;
}

int main()
{
    char s[20];
    while(~scanf("%d %d",&n,&m))
    {
        memset(mp,0,sizeof(mp));
        if(n==0&&m==0) break;
        int x;
        char c;
        for(int i=1; i<=n; i++)
        {
            scanf("%s", s);
            while(~scanf("%d%c",&x,&c))
            {
                mp[i][x+1]=1;
                if(c=='\n') break;
            }
        }
        int L=1,R=n,ans=n;
        while(L<=R)
        {
            int mid=(L+R)/2;
            if(hungary(mid))
            {
                ans=mid;
                R=mid-1;
            }
            else L=mid+1;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值