HDU - 6030 Happy Necklace(矩阵快速幂)

Happy Necklace
Little Q wants to buy a necklace for his girlfriend. Necklaces are single strings composed of multiple red and blue beads.
Little Q desperately wants to impress his girlfriend, he knows that she will like the necklace only if for every prime length continuous subsequence in the necklace, the number of red beads is not less than the number of blue beads.
Now Little Q wants to buy a necklace with exactly n beads. He wants to know the number of different necklaces that can make his girlfriend happy. Please write a program to help Little Q. Since the answer may be very large, please print the answer modulo 10^9+7.
Note: The necklace is a single string, {not a circle}.
Input
The first line of the input contains an integer T(1≤T≤10000), denoting the number of test cases.
For each test case, there is a single line containing an integer n(2≤n≤10^18), denoting the number of beads on the necklace.
Output
For each test case, print a single line containing a single integer, denoting the answer modulo 10^9+7.

Sample Input
2
2
3

Sample Output
3
4

题意:有一条项链由n个珠子(珠子有红、蓝两种颜色)组成,如果项链中每一个质数长度的连续子序列中,红色珠子的数量不少于蓝色珠子的数量,则这条项链就是好的,最后需要求有多少种组合的方式,使项链是好的。

思路:
列了一下后面的几种情况,可以找到一个规律f(n)=f(n-1)+f(n-3),然后因为这题的n给的范围很大,所以考虑用矩阵快速幂求解。
通过递推式得到关系矩阵A:
| 1 0 1 |
| 1 0 0 |
| 0 1 0 |
使得

对于n>3 存在
            | f(n-1) |   | f(n)   |
A^(n-3)  *  | f(n-2) | = | f(n-1) |
            | f(n-3) |   | f(n-2) |

代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <queue>
#include <stack>
#include <vector>
#include <set>
#include <map>
#include <list>
#include <deque>
#include <iomanip>
#include <iostream>
#include <algorithm>
using namespace std;

#define IOS                      \
    ios::sync_with_stdio(false); \
    cin.tie(0);                  \
    cout.tie(0)
#define lowbit(a) (a & (-a))
#define ll long long
const int inf = 0x3f3f3f3f;
const int maxn = 2e5 + 10;
const int minn = 1e3 + 10;
const double PI = acos(-1.0);
#define mod 1000000007
#define eps 1e-10
/*------------------------------------------------------*/

int N = 3;

struct Matrix
{
    ll mp[3][3];
    Matrix()
    {
        memset(mp, 0, sizeof(mp));
    }
    void init()
    {
        memset(mp, 0, sizeof(mp));
        for (int i = 0; i < N; i++)
            mp[i][i] = 1;
    }
};

Matrix mul(Matrix a, Matrix b)
{
    Matrix ans;
    for (int i = 0; i < N; i++)
        for (int j = 0; j < N; j++)
            for (int k = 0; k < N; k++)
                ans.mp[i][j] = ((ans.mp[i][j] % mod) + ((a.mp[i][k] % mod) * (b.mp[k][j] % mod)) % mod) % mod;
    return ans;
}

Matrix mat_pow(Matrix a, ll b)
{
    Matrix ans;
    ans.init();
    while (b)
    {
        if (b & 1)
            ans = mul(ans, a);
        a = mul(a, a);
        b >>= 1;
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        ll n;
        scanf("%lld", &n);
        if (n == 2)
            printf("3\n");
        else if (n == 3)
            printf("4\n");
        else if (n == 4)
            printf("6\n");
        else
        {
            Matrix cnt;
            cnt.init();
            cnt.mp[0][0] = 1, cnt.mp[0][1] = 0, cnt.mp[0][2] = 1;
            cnt.mp[1][0] = 1, cnt.mp[1][1] = 0, cnt.mp[1][2] = 0;
            cnt.mp[2][0] = 0, cnt.mp[2][1] = 1, cnt.mp[2][2] = 0;
            cnt = mat_pow(cnt, n - 4);
            printf("%lld\n", (cnt.mp[0][0] * 6 % mod + cnt.mp[0][1] * 4 % mod + cnt.mp[0][2] * 3 % mod) % mod);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值