数据结构实验之二叉树五:层序遍历 SDUT OJ3344

数据结构实验之二叉树五:层序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

Hint

 

Source

xam
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data ;
    struct node *L_child, *R_child;
};

struct node *Creat_Tree();
void Level_Order(struct node *);
char str[55];
int t;///作为控制变量,控制输出字符序列,建立二叉树
int main ()
{
    struct node *Root;
    int T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%s", str);
        t = 0;///每次输入新数据时清零
        Root = Creat_Tree();///建立二叉树
        Level_Order(Root);///层序遍历
        printf("\n");
    }
    return 0;
}

struct node *Creat_Tree()
{///先序遍历建立二叉树
    struct node *Root;
    char ch;
    ch = str[t++];///每次取一个字符用于建立树中的结点
    if(ch == ',')  Root = NULL;///如果字符为 “ , ” 按照题意为空结点
    else
    {
        Root = (struct node *)malloc(sizeof(struct node));
        Root->data = ch;
        Root->L_child = Creat_Tree();
        Root->R_child = Creat_Tree();
    }
    return Root;
};
void Level_Order(struct node *Root)
{
    int in, out;
    in = out = 0;
    struct node *p[55];///需要存储结点的地址,所以用指针数组
    p[in++] = Root;///模拟队列
    while(in > out)
    {
        if(p[out])
        {
            printf("%c", p[out]->data);
            p[in++] = p[out]->L_child;
            p[in++] = p[out]->R_child;
        }
        out++;
    }
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值