POJ 1442 优先队列大堆和小堆的维护

Black Box
TimeLimit: 1000ms MemoryLimit:10000KB
64-bit integer IO format:%lld
Problem Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.

Let us examine a possible sequence of 11 transactions:

Example 1

N Transaction i Black Box contents after transaction Answer

  (elements are arranged by non-descending)   

1 ADD(3) 0 3

2 GET 1 3 3

3 ADD(1) 1 1, 3

4 GET 2 1, 3 3

5 ADD(-4) 2 -4, 1, 3

6 ADD(2) 2 -4, 1, 2, 3

7 ADD(8) 2 -4, 1, 2, 3, 8

8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8

9 GET 3 -1000, -4, 1, 2, 3, 8 1

10 GET 4 -1000, -4, 1, 2, 3, 8 2

11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:

  1. A(1), A(2), …, A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

  2. u(1), u(2), …, u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, … and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), …, u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u§ <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), …, A(u§) sequence.

Input
Input contains (in given order): M, N, A(1), A(2), …, A(M), u(1), u(2), …, u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
SampleInput
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
SampleOutput
3
3
1
2

题意: 有两种操作,一是往黑盒中加入元素(ADD),二是GET操作输入一个序列长度,输出当前长度序列第i大的元素的值。
初始状态i=0,每次GET操作会使得i+1.

思路:由于是求输入序列中(黑盒中) 第i大的元素 所以 我们用大堆来存 前i-1小的数 ,用小堆来存第i到第k大的数 保证小堆顶部就是答案,每次将输入的序列存入小堆当中,如果小堆的最小数大于大堆的最大数则进行交换,保证小堆中所有的数都大于大堆,所以保证了小堆中堆顶元素就是第i大的元素 也就是答案。下面献上我的low b 代码

#include <iostream>
#include <queue>

using namespace std;

const int N = 30005;

int a[N];
priority_queue<int>bigque;
priority_queue<int,vector<int>,greater < int > >smallque;

int main()
{
    int n,m;

    cin >> n >>m;

    for(int i=1 ;i <= n; i++)
        cin >> a[i];

    int k=1;///计数变量

    for(int i=1;i<=m; i++)
    {
        int x;

        cin >> x;

        while(k <= x)
        {
            smallque.push(a[k]);///先压入小堆当中
            if(!bigque.empty() && bigque.top() > smallque.top())///如果大堆中的堆顶元素大于小堆堆顶元素则交换
            {
                int t=bigque.top();
                bigque.pop();

                smallque.push(t);

                t=smallque.top();
                smallque.pop();

                bigque.push(t);
            }
            k++;
        }
         int t=smallque.top();///答案输出
        cout<< t <<endl;
        smallque.pop();
        bigque.push(t);///因为i是递增的 所以先把数压入大堆中
    }
    return 0;
}

重点在于建两个优先队列的方法,想到就很容易写了,算是个涨姿势的题

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值