1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C
​1
​​ and C
​2
​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
​1
​​ , c
​2
​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C
​1
​​ to C
​2
​​ .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C
​1
​​ and C
​2
​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:

2 4

//dijkstra写,每次先找出来离起点最近的k点,(看k点是不是终点,或者从起点到这个点的距离已经为inf,决定结束循环),再更新从起点到b点(b从0到n-1)的最短距离,同时更新最短路径条数以及最多救援人员
#include<bits/stdc++.h>
using namespace std;
const int N=1005;
int n,m,x,y;
int inf = 0x3fffffff;
int k[N];//每个城市的救援人数
int kk[N];//每条路径的最多救援人数
int mmap[N][N];//城市间的距离
int vis[N];//从起点x到i有没有访问过
int dis[N];//从起点到i的距离
int path[N];//从起点到i的最短路径条数(和起点有连线的初始化为1,其余为0)
void dijkstra()
{
    int i,j;
    memset(dis,0x3f3f3f3f,sizeof(dis));
    dis[x]=0;
    kk[x]=k[x];
    path[x]=1;
    for(j=0; j<n; j++)
    {
       int mi=inf;
        int pos=-1;
        for(i=0; i<n; i++)
        {
            if(vis[i])
                continue;
            if(dis[i]<mi)
            {
                mi=dis[i];
                pos=i;
            }
        }
        if(pos==y||mi==inf)
            break;
        vis[pos]=1;
        for(i=0; i<n; i++)
        {
            if(vis[i]||mmap[pos][i]==0)
                continue;
            if(dis[i]>dis[pos]+mmap[pos][i])
            {
                dis[i]=dis[pos]+mmap[pos][i];
                path[i]=path[pos];//从pos点到i点只有一条路
                kk[i]=kk[pos]+k[i];
            }
            else if(dis[i]==mmap[pos][i]+dis[pos])
            {
                path[i]+=path[pos];
                if(kk[i]<kk[pos]+k[i])
                    kk[i]=kk[pos]+k[i];
            }
        }
    }
}
int main()
{
    int i;
    scanf("%d %d %d %d",&n,&m,&x,&y);
    for(i=0; i<n; i++)
    {
        scanf("%d",&k[i]);
    }
    int u,v,w;
    memset(vis,0,sizeof(vis));
    memset(mmap,0x3f3f3f3f,sizeof(mmap));
    memset(path,0,sizeof(path));
    while(m--)
    {
        scanf("%d %d %d",&u,&v,&w);
        if(mmap[u][v]>w)
            mmap[u][v]=mmap[v][u]=w;
       // if(u==x||v==x)
            //path[u]=path[v]=1;
    }
    dijkstra();
    printf("%d %d\n",path[y],kk[y]);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值