F - Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:给三个数n,m,w。有n个地方,这n个地方之间有m条通路(双向路),走通路会用时t;有w条虫洞(单向路),走虫洞会减少时间t。问从1
出发再回到1的时间能不能是出发之前的时间(在路上消耗时间为负)。
思路:判断有没有负权回路。

/**/
#include<iostream>
#include<cstring>
using namespace std;
const int inf=0x3f3f3f3f;
int main()
{
    int t,i,n,m,k,e,x,y,z;
    int a[6010],b[6010],c[6010],dis[510];
    cin>>t;
    while(t--)
    {
        cin>>n>>m>>k;
        e=0;
        for(i=1;i<=m;i++)
        {
            cin>>x>>y>>z;
            a[++e]=x;
            b[e]=y;
            c[e]=z;
            a[++e]=y;
            b[e]=x;
            c[e]=z;
        }
        for(i=1;i<=k;i++)
        {
            cin>>x>>y>>z;
            a[++e]=x;
            b[e]=y;
            c[e]=-z;
        }
        for(i=1;i<=n;i++)
        {
            dis[i]=inf;
        }
        dis[1]=0;
        while(dis[1]>=0)
        {
            int flag=0;
            for(i=1;i<=e;i++)
            {
                if(dis[b[i]]>dis[a[i]]+c[i])
                {
                     dis[b[i]]=dis[a[i]]+c[i];
                     flag=1;
                }
            }
            if(!flag)
                break;
        }
        if(dis[1]<0)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值