过滤多余的空格(逐句精解)

一个句子中也许有多个连续空格,过滤掉多余的空格,只留下一个空格

输入格式
一行,一个字符串(长度不超过 200200),句子的头和尾都没有空格。

输出格式
过滤之后的句子。

输出时每行末尾的多余空格,不影响答案正确性

样例输入
Hello world.This is c language.

样例输出
Hello world.This is c language.

1、定义头文件

#include <iostream>
#include <string>
#include <stdio.h>

2、定义数据

  • i 最大循环次数
  • pos当前是位置
char a[205];
int i = 250;
int pos;

3、输入数据

gets(a);

4、转换为string

string s(a);

5、处理数据

  • 如果发现是两个空格,则换成一个空格
  • find返回出现字符串的位置下标
  • replace表示替换,pos:从pos的位置, 2:替换两个,“ ”:替换为“ ”
while (i--) {
    if ((pos = s.find("  ")) != string::npos){
        s.replace(pos, 2, " ");
    }
}

6、输出数据

cout << s;

7、return 0

return 0;

完整代码

#include <iostream>
#include <string>
#include <stdio.h>
using namespace std;
char a[205];
int main(){
    gets(a);
    string s(a);
    int i = 250;
    int pos;
    while (i--) {
        if ((pos = s.find("  ")) != string::npos){
            s.replace(pos, 2, " ");
        }
    }
    cout << s;
    return 0;
}
  • 2
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值