Kth number----主席树模板

Problem Description

Give you a sequence and ask you the kth big number of a inteval.

 

 

Input

The first line is the number of the test cases. 
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere. 
The second line contains n integers, describe the sequence. 
Each of following m lines contains three integers s, t, k. 
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]

 

 

Output

For each test case, output m lines. Each line contains the kth big number.

 

 

Sample Input

 

1

10 1

1 4 2 3 5 6 7 8 9 0

1 3 2

 

 

Sample Output

 

2

主席树的模板

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
#include <iostream>
using namespace std;
const int maxn = 100000;
int n,m,tot;
int a[maxn+10],rt[maxn+10];
struct node
{
    int l,r,sum;
}tree[maxn*40];
vector<int>v;
int getid(int x)//获取x在vector里的排序
{
    return lower_bound(v.begin(),v.end(),x)-v.begin()+1;
}
void build (int l,int r,int &x)//建树
{
    x=++tot;
    tree[x].sum=0;
    if(l==r)return ;
    int m=(l+r)>>1;
    build(1,m,tree[x].l);//tree[x].l储存的是左区间节点编号
    build(m+1,r,tree[x].r);
}
void update(int l,int r,int &x,int y,int k)
{
    x=++tot;
    tree[x]=tree[y];
    tree[x].sum++;//向下更新
    if(l==r)//找到叶子结点
        return ;
        int m=(l+r)>>1;
        if(k<=m)
            update(1,m,tree[x].l,tree[y].l,k);//如果更新的点在左边,则向左边找
        else
            update(m+1,r,tree[x].r,tree[y].r,k);//反之右边
}
int query(int l,int r,int x,int y,int k)//查找
{
    if(l==r)return l;
    int m=(l+r)>>1;
    int sum=tree[tree[y].l].sum-tree[tree[x].l].sum;
    //得到sum是当前结点左边的后区间减去前一个区间得到中间区间的值的个数
    if(k<=sum)
        return query(l,m,tree[x].l,tree[y].l,k);
    else return query(m+1,r,tree[x].r,tree[y].r,k-sum);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);//n个数,m次查询
        v.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            v.push_back(a[i]);
        }
        sort(v.begin(),v.end());
        v.erase(unique(v.begin(),v.end()),v.end());//去重
        int cnt=v.size();
        tot=0;
        build(1,cnt,rt[0]);//建立空树
        for(int i=1;i<=n;i++)
            update(1,cnt,rt[i],rt[i-1],getid(a[i]));//建立不同版本的树
            while(m--)
            {
                int l,r,x;
                scanf("%d%d%d",&l,&r,&x);
                int ans=v[query(1,cnt,rt[l-1],rt[r],x)-1];//得到答案
                printf("%d\n",ans);
            }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值