HDU - 1495 非常可乐(bfs or 数论)

HDU - 1495 非常可乐

                                               非常可乐

                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                               Total Submission(s): 36201    Accepted Submission(s): 14091

 

Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。 
 
Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 
Sample Input
7 4 3 4 1 3 0 0 0
 
Sample Output
NO 3
 
 
 
思路:
给出的两个杯子是没有刻度的,所以每次只能全部倒出或者倒满另一个杯子,这样就有6种情况:S->N,S->M,N->S,N->M,M->S,M->N。最少的次数就用BFS做。bfs时六种情况全列出来就好了,用vis数组标记一下哪一种状态已经经历过了。
 
附上dalao的数论解法: https://blog.csdn.net/V5ZSQ/article/details/52097459 🤯
 
bfs Code:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;

struct node
{
	int a, b, c;
	int step;
	node(int a = 0, int b = 0, int c = 0, int step = 0) : a(a), b(b), c(c), step(step) {}
};

int s, n, m;
bool vis[110][110][110];

int bfs()
{
	memset(vis, false, sizeof(vis));
	queue<node> q;
	q.push(node(s, 0, 0, 0));
	vis[s][0][0] = true;
	node now, w;
	int k;
	while (!q.empty())
	{
		now = q.front();
		q.pop();
		if ((now.a == now.b && now.c == 0) || (now.a == now.c && now.b == 0) || (now.b == now.c && now.a == 0))
		{
			return now.step;
		}
		if (now.a)
		{
			if (k = min(now.a, n - now.b))
			{
				w = node(now.a - k, now.b + k, now.c, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
			if (k = min(now.a, m - now.c))
			{
				w = node(now.a - k, now.b, now.c + k, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
		}
		if (now.b)
		{
			if (k = min(s - now.a, now.b))
			{
				w = node(now.a + k, now.b - k, now.c, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
			if (k = min(now.b, m - now.c))
			{
				w = node(now.a, now.b - k, now.c + k, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
		}
		if (now.c)
		{
			if (k = min(s - now.a, now.c))
			{
				w = node(now.a + k, now.b, now.c - k, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
			if (k = min(now.c, n - now.b))
			{
				w = node(now.a, now.b + k, now.c - k, now.step + 1);
				if (!vis[w.a][w.b][w.c])
				{
					vis[w.a][w.b][w.c] = true;
					q.push(w);
				}
			}
		}
	}
	return 0;
}

int main()
{
	while (scanf("%d%d%d", &s, &n, &m) != EOF && s && n && m)
	{
		if (s & 1)
		{
			printf("NO\n");
			continue;
		}
		int ans = bfs();
		if (ans)
			printf("%d\n", ans);
		else
			printf("NO\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值