PTA Queueing at Bank (25分)

释放无限光明的是人心,制造无边黑暗的也是人心,光明和黑暗交织着,厮杀着,这就是我们为之眷恋又万般无奈的人世间。

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include <numeric>
#include <climits>//INT_MAX
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
//#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
int n,k,ct;
const int maxn=1e4+10;
const int ET=8*60*60, LT=17*60*60;
struct node {
    int wc;
}ck[110];
struct gk{
    int dj, p;
    bool operator<(const gk&x)
    {
        return dj<x.dj;
    }
}a[maxn];
int fdmi()
{
    int id=0;
    for (int i=0; i<k; i++)
    {
        if (ck[i].wc<ck[id].wc)
            id =i;
    }
    return id;
}
int main()
{
    scanf("%d%d", &n, &k);
    for(int i=0; i<110; i++)
        ck[i].wc=ET;
    for(int i=0; i<n; i++)
    {
        int hh, mm, ss, p, sj;
        scanf("%d:%d:%d %d", &hh, &mm, &ss, &p);
        sj=hh*3600+mm*60+ss;
        if (sj>=LT)
            continue;
        if (p>60)
            p=60;
        a[ct].dj=sj;
        a[ct].p=p*60;
        ct++;
    }
    sort(a,a+ct);
    int jg=0;
    for (int i=0; i<ct; i++)
    {
        int minw=fdmi();
        if (a[i].dj<ck[minw].wc)
        {
            jg+=ck[minw].wc-a[i].dj;
            ck[minw].wc+=a[i].p;
        }
        else
            ck[minw].wc=a[i].dj+a[i].p;
    }
    printf("%.1f", jg*1.0/ct/60);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值