PTA Hashing (25分)

我们活在这个世界上,没有一件事是虚空而生的,你站在光里背后就会有阴影,站在黑暗里心中也可能有光明,所以我们必须得承认,有一部分人或许丧失了初心,但也有一部分人用生命来践行诺言。

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctime>
#include <cctype>
#include <bitset>
#include <utility>
#include <sstream>
#include <complex>
#include <iomanip>
#include <numeric>
#include<unordered_set>
#include <climits>//INT_MAX
#define PP pair<ll,int>
#define inf 0x3f3f3f3f
#define llinf 0x3f3f3f3f3f3f3f3fll
#define dinf 1000000000000.0
#define PI 3.1415926
//#include<bits/stdc++.h>
typedef long long ll;
using namespace std;
const int N=1e5+10;
const int maxn=120000;
bool isPrime(int n)
{
    if(n<=1)
        return false;
    int sqr=(int)sqrt(1.0*n);
    for(int i=2; i<=sqr; i++)
    {
        if(n%i==0)
            return false;
    }
    return true;
}

bool hs[maxn];
int main()
{
    int n,T,a;
    scanf("%d%d",&T,&n);
    while(isPrime(T)==false)
        T++;
    for(int i=0; i<n; i++)
    {
        scanf("%d",&a);
        int m=a%T;
        if(hs[m]==false)
        {
            hs[m]=true;
            if(i==0)
                printf("%d",m);
            else \
                printf(" %d",m);
        }
        else
        {
            int ls;
            for(ls=1; ls<T; ls++)
            {
                m=(a+ls*ls)%T;
                if(hs[m]==false)
                {
                    hs[m]=true;
                    if(i==0)
                        printf("%d",m);
                    else
                        printf(" %d",m);
                    break;
                }
            }
            if(ls>=T)
            {
                if(i>0)
                    printf(" ");
                printf("-");
            }
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值