poj2454 Jersey Politics (随机化算法)

Jersey Politics

In the newest census of Jersey Cows and Holstein Cows, Wisconsin cows have earned three stalls in the Barn of Representatives. The Jersey Cows currently control the state’s redistricting committee. They want to partition the state into three equally sized voting districts such that the Jersey Cows are guaranteed to win elections in at least two of the districts.

Wisconsin has 3K (1 <= K <= 60) cities of 1,000 cows, numbered 1…3K, each with a known number (range: 0…1,000) of Jersey Cows. Find a way to partition the state into three districts, each with K cities, such that the Jersey Cows have the majority percentage in at least two of districts.

All supplied input datasets are solvable.

Input
  • Line 1: A single integer, K

  • Lines 2…3*K+1: One integer per line, the number of cows in each city that are Jersey Cows. Line i+1 contains city i’s cow census.
    Output

  • Lines 1…K: K lines that are the city numbers in district one, one per line

  • Lines K+1…2K: K lines that are the city numbers in district two, one per line

  • Lines 2K+1…3K: K lines that are the city numbers in district three, one per line

Sample Input

2
510
500
500
670
400
310

Sample Output

1
2
3
6
5
4

Hint

Other solutions might be possible. Note that “2 3” would NOT be a district won by the Jerseys, as they would be exactly half of the cows.

思路:

显然要是的两个区域都大于一半,肯定要用票数最大的前2k个
升序排列这3k个数,sum1=前k个数的和,sum2=中间k个数的和
如果不满足条件,则从第一组中随机找一个数,第二组中随机找一个数,两者交换直到满足条件

总结:似乎这种想不出来怎么换的就可以直接尝试随机换

code:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxm=205;
struct Node{
    int v,id;
}e[maxm];
bool cmp(Node a,Node b){
    return a.v>b.v;
}
int k;
signed main(){
    scanf("%d",&k);
    for(int i=1;i<=k*3;i++){
        scanf("%d",&e[i].v);
        e[i].id=i;
    }
    sort(e+1,e+1+k*3,cmp);
    int sum1=0,sum2=0;
    for(int i=1;i<=k;i++){
        sum1+=e[i].v;
        sum2+=e[i+k].v;
    }
    while(sum1<=500*k||sum2<=500*k){
        int x=rand()%k+1;
        int y=rand()%k+1+k;
        sum1-=e[x].v;
        sum1+=e[y].v;
        sum2-=e[y].v;
        sum2+=e[x].v;
        swap(e[x],e[y]);
    }
    for(int i=1;i<=k*3;i++){
        printf("%d\n",e[i].id);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值