I - Strategic Game (二分图)

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:
在这里插入图片描述

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Output
1
2
Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)
Sample Output
1
2

题意

 Bob想保卫他的城镇,所以就安排士兵巡逻。因为兵力有限,就尽可能少的安排士
 兵,并使士兵能尽快到达邻近点。

思路

    找这个图最小点覆盖数,用二分图找出最大匹配数,最小点覆盖数就等于最大匹配数
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef long long ll;
using namespace std;
const int N=2010;
const int INF=0x3f3f3f3f3f;
int line[N][N],girl[N],used[N];
int n,m,h,b;
bool found(int x)
{
    for(int i=0;i<n;i++)
    {
        if(line[x][i]&&!used[i])
        {
            used[i]=1;
            if(girl[i]==0||found(girl[i]))
            {
                girl[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int match()
{
    int sum=0;
    memset(girl,0,sizeof(girl));
    for(int i=0;i<n;i++)
    {
        memset(used,0,sizeof(used));
        if(found(i))
            sum++;
    }
    return sum/2;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(line,0,sizeof(line));
        for(int i=1;i<=n;i++)
        {
            scanf("%d:(%d)",&h,&m);
             for(int j=1;j<=m;j++)
             {
                 scanf("%d",&b);
                 line[h][b]=line[b][h]=1;
             }
        }
        printf("%d\n",match());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值