L - Computer HDU - 2196 (树形dp)

A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.
在这里插入图片描述

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
Sample Input
5
1 1
2 1
3 1
1 1
Sample Output
3
2
3
4
4

题意: 给你一棵树,求树上各点能到达的最远距离。

思路: 对于任意一个节点,他能到达的最远节点一定是他子树的一个节点,或者经过他父亲到达的一个节点。
搜素两次,一次记录最远距离,一次寻找答案,用dp[u][0] 表示在u的子树下的最远距离,用dp[u][1]表示u的子树下的次远距离,用dp[u][2] 表示通过u的父亲走过的最远距离。

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef unsigned long long ull;
typedef long long ll;
using namespace std;
const int N=1e4+10;
const int prime=2333317;
const int INF=0x3f3f3f3f3f;
int n,k;
int dp[N][3],head[N];
struct node
{
    int v,w,next;
}edge[N];
void init()
{
    memset(dp,0,sizeof(dp));
    memset(head,-1,sizeof(head));
    memset(edge,-1,sizeof(edge));
    k=0;
}
void add(int u,int v,int w)
{
    edge[k].v=v;
    edge[k].w=w;
    edge[k].next=head[u];
    head[u]=k++;
}
void tree(int u,int pre)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        tree(v,u);
        int dis=edge[i].w;
        int temp=dp[v][0]+dis;
        if(temp>=dp[u][0])
        {
            dp[u][1]=dp[u][0];
            dp[u][0]=temp;
        }
        else if(temp>dp[u][1])
        {
            dp[u][1]=temp;
        }
    }
}
void upp(int u,int pre)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(dp[u][0]==dp[v][0]+edge[i].w)
        {
            dp[v][2]=max(dp[u][2],dp[u][1])+edge[i].w;
        }
        else
        {
            dp[v][2]=max(dp[u][2],dp[u][0])+edge[i].w;
        }
        upp(v,u);
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        int y,w;
        init();
        for(int i=2;i<=n;i++)
        {
            scanf("%d%d",&y,&w);
            add(y,i,w);
        }
        tree(1,-1);
        upp(1,-1);
        for(int i=1;i<=n;i++)
        {
            printf("%d\n",max(dp[i][2],dp[i][0]));
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值