PTA 甲级1025 PAT Ranking

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
//建表(结构体)
struct student {
	char number[13];
	int score;
	int fr;
	int ln;
	int lr;
}stu[30000];
//排序
bool cmp(student a, student b) {
	if (a.score != b.score) {
		return a.score > b.score;
	}
	else {
		return strcmp(a.number, b.number)<0;
	}
}
int main() {
	int num = 0;
	int st = 0;
	int en = 0;
	int n = 0;
	scanf("%d", &n);
	for (int i = 1;i <=n ;i++) {
        //考点数输入
		int k;
		scanf("%d", &k);
		st = num;
        //信息输入
		for (int j = 0;j < k;j++) {
			scanf("%s %d", stu[num].number, &stu[num].score);
			stu[num].ln = i;
			num++;
		}
		en = num;
        //考点排序
		sort(stu+st, stu+en, cmp);
        //考点排名
		stu[st].lr = 1;
		for (int j = st+1;j <= en;j++) {
			if (stu[j].score == stu[j - 1].score) {
				stu[j].lr = stu[j - 1].lr;
			}
			else {
				stu[j].lr = j-st+1;
			}
		}
	}
	sort(stu, stu + num,cmp);
    //总排名
	stu[0].fr = 1;
    //输出
	printf("%d\n", num);
    //输出
	printf("%s %d %d %d\n",stu[0].number,stu[0].fr,stu[0].ln,stu[0].lr);
	for (int i = 1;i < num;i++) {
		if (stu[i].score == stu[i - 1].score) {
			stu[i].fr = stu[i - 1].fr;
		}
		else {
			stu[i].fr = i+1;
		}
        //输出
		printf("%s %d %d %d\n",stu[i].number,stu[i].fr,stu[i].ln,stu[i].lr);
		
	}
	return 0;
}

这道题主要涉及的是sort函数的使用,排名算法。因为刚学C和C++所以语法混用比较厉害,过两天应该会好一些。

几个坑点:
==一直写成=,

题述The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.漏了

stu数组长度其实是30000不是300,

return strcmp(a.number, b.number)<0;

scanf要有&,char[]不需要&

stu[j].lr = j-st+1;而不是=stu[j-1].lr+1

stu[i].fr = i+1;而不是=stu[i-1].fr+1

printf("%d\n", num);漏了

每次都死在一些奇奇怪怪的细节上
希望这段时间的做题能让自己的细节把握能力有一个质的提升叭

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值