1107 Social Clusters

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K
​i
​​ : h
​i
​​ [1] h
​i
​​ [2] … h
​i
​​ [K
​i
​​ ]

where K
​i
​​ (>0) is the number of hobbies, and h
​i
​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
并查集
一开始思路想错了,我想用人来包含兴趣,不好做,因该用兴趣来包含人,即第几个兴趣有哪些人喜欢

#include<iostream>
#include<cstdio>
#include<algorithm>
const int maxn = 1005;
using namespace std;
int p[maxn],bk[maxn],c[maxn],n;
bool cmp(int a,int b){
	return a>b;
}
int findf(int k){
	int a=k;
	while(k!=p[k]) k=p[k];
//	while(a!=p[a]){
//		int z=a;
//		a=p[a];
//		p[z] = k;
//	}
	return k;	
}
void Union(int a,int b){
	int fa=findf(a);
	int fb=findf(b);
	if(fa!=fb) p[fa] = fb;
}
int main(){
	cin>>n;
	for(int i=1;i<=n;i++) p[i] = i;
	int k,x; 
	for(int i=1;i<=n;i++){
		scanf("%d: ",&k);
		for(int j=0;j<k;j++){
			cin>>x;
			if(!c[x]) c[x] = i;
			Union(i,c[x]);
		}
	}
	for(int i=1;i<=n;i++){
		bk[findf(i)]++;
	}
	
	int cnt=0;
	for(int i=1;i<=n;i++){
		if(bk[i]) cnt++;
	}
	sort(bk+1,bk+n+1,cmp);
	cout<<cnt<<endl;
	for(int i=1;i<=cnt;i++){
		if(i<cnt) cout<<bk[i]<<' ';
		else cout<<bk[i];
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
非常抱歉,我的回答里有误,`clusters.erase`应该改为`clusters.erase(clusters.begin() + minCluster2)`。这是因为 `clusters` 是一个 `vector`,我们需要使用 `vector` 的 `erase` 函数来删除其中的元素。 完整的代码如下: ```c++ #include <iostream> #include <vector> #include <cmath> #include <limits> using namespace std; struct DataPoint { double value; int cluster; }; double getDistance(const DataPoint& p1, const DataPoint& p2) { return fabs(p1.value - p2.value); } void mergeClusters(vector<DataPoint>& data, int cluster1, int cluster2) { for (auto& point : data) { if (point.cluster == cluster2) { point.cluster = cluster1; } } } void hierarchicalClustering(vector<DataPoint>& data) { int n = data.size(); vector<int> clusters(n); for (int i = 0; i < n; ++i) { clusters[i] = i; } while (n > 1) { double minDist = numeric_limits<double>::max(); int minCluster1 = -1, minCluster2 = -1; for (int i = 0; i < n-1; ++i) { for (int j = i+1; j < n; ++j) { double dist = getDistance(data[i], data[j]); if (dist < minDist) { minDist = dist; minCluster1 = clusters[i]; minCluster2 = clusters[j]; } } } mergeClusters(data, minCluster1, minCluster2); clusters.erase(clusters.begin() + minCluster2); for (auto& point : data) { if (point.cluster > minCluster2) { --point.cluster; } } --n; } } int main() { vector<DataPoint> data = {{1.0, 0}, {2.0, 1}, {5.0, 2}, {6.0, 3}, {7.0, 4}, {8.0, 5}}; hierarchicalClustering(data); for (const auto& point : data) { cout << point.value << " " << point.cluster << endl; } return 0; } ``` 该程序可以将输入的数据按照差值进行聚类,并输出每个数据点所属的簇的编号。输入的数据是一个包含六个数据点的向量,每个数据点包含数据本身和所属的簇的编号。在程序中,我们首先对每个数据点初始化一个簇的编号,然后进行层次聚类,最终得到每个数据点所属的最终簇的编号。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值