1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
读题的时候并没有想到完全二叉树,虽然看到了complete,接着看题意,虽然看到了完全二叉树,但是还是不会写。
这题主要是考察完全二叉树的性质的,首先读入数据然后再用这些数据构建完全二叉树,然后层次遍历。
完全二叉树的properties
1.用数组存储较方便,根节点为1(数组的下标)
2.完全二叉树的任意一个节点x,它的左孩子下标为2x,右孩子的下标为2x+1,
3.数组存放的顺序恰好为该完全二叉树的层次遍历的顺序
4.先序遍历完全二叉树得到的是有序序列
5.判断某个节点是否为叶子节点的标志:该节点的左孩子 > n,无需判断有孩子。如果判断某个节点是否为空的标志:该节点下标>n

总结:
这题完全考的是完全二叉树的性质,主要是递归建树要理解透彻
首先是递归,递归主要看的是根再合适插入(或者根据题目的要求),因为CST的的先序遍历得到的是有序序列,所以根据这个性质来递归建树,递归2大特性:递归边界和递归式,边界就是上面说的第5点,而递归式只要按照先序的顺序来对根进行插入,最后按顺序输出就可以了

#include<iostream>
#include<algorithm>
#include<vector>
const int maxn=1005;
using namespace std;
int CST[maxn],data[maxn],n,index;
void create(int root){
	if(root > n) return;
	create(root * 2);
	CST[root] = data[index++];
	create(root * 2 + 1);
}
int main(){
 	cin>>n;
 	for(int i=0;i<n;i++) cin>>data[i];
 	sort(data,data+n);
 	create(1);
 	for(int i=1;i<=n;i++){
 		if(i<n) cout<<CST[i]<<' ';
		else cout<<CST[i]; 
	 }
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值