1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

hierarchy 英[ˈhaɪərɑːki]
美[ˈhaɪərɑːrki]
n. 等级制度(尤指社会或组织); 统治集团; 层次体系;

pedigree 英[ˈpedɪɡriː]
美[ˈpedɪɡriː]
n. 动物血统记录; 动物纯种系谱; 家谱; 门第; 世系; 起源;
adj. 优良品种的; 纯种的;

不难,唯一注意的是要考虑只有根节点的时候,也不是要考虑。。这题正常写就不会出什么问题

#include<iostream>
#include<cstdio>
#include<queue>
#include<vector>
#include<cmath>
const int maxn=105;
using namespace std;
int n,m,bk[maxn],maxx=1;
vector<int> v[maxn];
void dfs(int root,int depth){
	if(!v[root].size()){
		bk[depth]++;
	}
	if(maxx < depth) maxx=depth;
	for(int i=0;i<v[root].size();i++){
		dfs(v[root][i],depth+1);
	}
}
int main(){
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int p,k;
		cin>>p>>k;
		while(k--){
			int a;
			cin>>a;
			v[p].push_back(a);
		}
	}
	dfs(1,1);
	for(int i=1;i<=maxx;i++){
		if(i<maxx) cout<<bk[i]<<' ';
		else cout<<bk[i];
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值