1066 Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
AVL树模板题吧,PAT AVL考的很少,本来不想做的,但是感觉侥幸心里不好,多学一点也没什么坏处,AVL我觉得模板行很强,就不再赘述了,另外如果不会,这题直接输出中位数也能得到17分

模板

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node{
	int v,height;
	node *lchild,*rchild;
}*root;
//生成新节点
node* newNode(int v){
	node* Node = new node;
	Node->v = v;
	Node->height=1;
	Node->lchild=Node->rchild=NULL;
	return Node;
} 
//获得树的高度
int getheight(node* root){
	if(root == NULL) return 0;
	return root->height;
} 
//更新节点高度
void updateheight(node* root){
	//int lh=getheight(root->lchild);
	//int rh=getheight(root->rchild);
	root->height= max(getheight(root->lchild),getheight(root->rchild)) + 1; 
} 
//计算平衡因子
int getbalancefactor(node* root){
	return getheight(root->lchild) - getheight(root->rchild);
} 
//左旋
void L(node* &root){
	node* temp=root->rchild;
	root->rchild = temp->lchild;
	temp->lchild=root;
	updateheight(root);
	updateheight(temp);
	root=temp;
} 
//右旋
void R(node* &root){
	node* temp=root->lchild;
	root->lchild=temp->rchild;
	temp->rchild=root;
	updateheight(root);
	updateheight(temp);
	root=temp;
	
} 
//插入v的节点 
void insert(node* &root,int v){
	if(root == NULL){
		root = newNode(v);
		return;
	}
	if(v < root->v){
		insert(root->lchild,v);
		updateheight(root);
		if(getbalancefactor(root) == 2){//L型 
			if( getbalancefactor(root->lchild) == 1) {//LL型  
			R(root); 
		}else if(getbalancefactor(root->lchild) == -1){//LR型 
			L(root->lchild);
			R(root);
		}
	}
}
	else{
		insert(root->rchild,v);
		updateheight(root);
		if(getbalancefactor(root) == -2){//R型 
			if(getbalancefactor(root->rchild) == -1){//RR型 
				L(root); 
			}else if(getbalancefactor(root->rchild) == 1){//Rl型 
				R(root->rchild);
				L(root); 
			}
		}
	}
} 

//建树(撸树)
node* create(int date[],int n) {
	node* root =NULL;
	for(int i=0;i<n;i++){
		insert(root,date[i]);
	}
	return root;
} 
int main(){
	int n,v;
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>v;
		insert(root,v);
	}
	cout<<root->v;
	return 0;
}

输出中位数 17分
算是AVL的性质吧

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int main(){
	int n,a[20];
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i];
	}
	sort(a,a+n);
	cout<<a[n/2];
	return 0;
}

参考
算法笔记上机训练P326

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值