数据结构——树状数组

定义

树状的数组 (废话,你就是偷懒不想查)

作用

求出一段区间元素共同计算得到的值

原理

其实就是简化过的线段树啦 (你是不是懒癌发作了)
不过树状数组求出的是从1开始的连续区间,若不从1开始,还得计算两个值再对这两个值计算得出答案

模板

#define lowbit(x) x&(-x) 
int tree[maxn]; 
int n;
void build(int n)
{
	for(int i = 1; i <= n; i++){
		int j = 0;
		while((1<<j) & i == 0) tree[i] += tree[i^(1<<j)], j++; 
	} 
} 

int query(int d)
{
	int ans = 0;
	for(int i = d; i > 0; i -= lowbit(i))
		ans += tree[i];
	return ans; 
} 

void update(int d, int val)
{
	for(int i = d; i <= n; i += lowbit(i))
		tree[i] += val; 
} 

例题

POJ - 1804 Brainman

Description

Background
Raymond Babbitt drives his brother Charlie mad. Recently Raymond counted 246 toothpicks spilled all over the floor in an instant just by glancing at them. And he can even count Poker cards. Charlie would love to be able to do cool things like that, too. He wants to beat his brother in a similar task.

Problem
Here’s what Charlie thinks of. Imagine you get a sequence of N numbers. The goal is to move the numbers around so that at the end the sequence is ordered. The only operation allowed is to swap two adjacent numbers. Let us try an example:
Start with: 2 8 0 3
swap (2 8) 8 2 0 3
swap (2 0) 8 0 2 3
swap (2 3) 8 0 3 2
swap (8 0) 0 8 3 2
swap (8 3) 0 3 8 2
swap (8 2) 0 3 2 8
swap (3 2) 0 2 3 8
swap (3 8) 0 2 8 3
swap (8 3) 0 2 3 8

So the sequence (2 8 0 3) can be sorted with nine swaps of adjacent numbers. However, it is even possible to sort it with three such swaps:
Start with: 2 8 0 3
swap (8 0) 2 0 8 3
swap (2 0) 0 2 8 3
swap (8 3) 0 2 3 8

The question is: What is the minimum number of swaps of adjacent numbers to sort a given sequence?Since Charlie does not have Raymond’s mental capabilities, he decides to cheat. Here is where you come into play. He asks you to write a computer program for him that answers the question. Rest assured he will pay a very good prize for it.

Input

The first line contains the number of scenarios.
For every scenario, you are given a line containing first the length N (1 <= N <= 1000) of the sequence,followed by the N elements of the sequence (each element is an integer in [-1000000, 1000000]). All numbers in this line are separated by single blanks.
Output

Start the output for every scenario with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the minimal number of swaps of adjacent numbers that are necessary to sort the given sequence. Terminate the output for the scenario with a blank line.

Sample Input

4
4 2 8 0 3
10 0 1 2 3 4 5 6 7 8 9
6 -42 23 6 28 -100 65537
5 0 0 0 0 0

Sample Output

Scenario #1:
3

Scenario #2:
0

Scenario #3:
5

Scenario #4:
0

分析

求逆序对数,典型的灭灯法(将元素按从小到大依次去掉,然后每次统计灭灯位置前面还有多少未灭的灯,即为逆序对数),树状数组这里比线段树要好很多。
AC代码:

#include <cstdio>
#include <algorithm> 
#include <cstring> 
using namespace std;

#define maxn 1005
int tree[maxn]; 
#define lowbit(x) x&(-x) 
struct Node{
	int dex, val;
} num[maxn]; 
int n; 
bool cmp(Node a, Node b)
{
	if(a.val == b.val) return a.dex < b.dex; 
	return a.val < b.val;
} 

void build(int n)
{
	for(int i = 1; i <= n; i++){
		int j = 0;
		while(((1<<j) & i) == 0) tree[i] += tree[i-(1<<j)], j++; 
	} 
} 

int query(int d)
{
	int ans = 0;
	for(int i = d; i > 0; i -= lowbit(i))
		ans += tree[i];
	return ans; 
} 

void update(int d, int val)
{
	for(int i = d; i <= n; i += lowbit(i))
		tree[i] += val; 
} 
void solve(int t)
{
	for(int i = 0; i < maxn; i++)
		tree[i] = 1; 
	int res = 0;
	scanf("%d", &n);
	for(int i = 1; i <= n; i++)
		scanf("%d", &num[i].val),
		num[i].dex = i; 	
	build(n);	
	sort(num+1, num+1+n, cmp);
	for(int i = 1; i <= n; i++){
		int d = num[i].dex;
		update(d, -1);
		res += query(d);  
	} 
	printf("Scenario #%d:\n%d\n\n", t, res); 
} 

int main()
{
	int t; 
	scanf("%d", &t);
	for(int i = 1; i <= t; i++)
		solve(i); 
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值