PAT甲级 1001 A+B Format(字符串)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a,b <= 1000000.The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

分析

这是一道字符串处理的问题。我自己的首先想法是需要将求和结果转换为字符串,然后按照我自己的日常习惯,从最后一位开始算,每三位花一个逗号。对于求和结果可分为以下几种情况:
负数:
  ①到第一位数字正好分逗号,如:-333,333,333
  ②到负号时正好分逗号,如:-33,333,333
正数:
  ③到第一位数字分逗号,如:333,333,333

#include<iostream>
#include<string>
using namespace std;

int main(){
    int a, b, j = 0, length;
    int sum = 0;
    string s;
    cin >> a >> b;
    sum = a + b;
    s = to_string(sum);
    length = s.length();
    for(int i = length - 1; i >=0; i--){
        j++;
        if(i > 0 && s[i-1] == '-') continue; //解决①这个问题
        if(j % 3 == 0 && i != 0){ //解决② ③这个问题。只要是第一位,无论是数字、负号,全都不分逗号
            s.insert(length - j, ",");
        }
    }
    cout << s;
    return 0;
}

注意: 因为每次插入一个逗号,字符串的长度都会变长,而循环的次数应该是原始的字符串长度,所以应该在开始的时候获取由和转换的字符串的长度。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值