POJ1979 红与黑 深刻反省

题目

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 56953 Accepted: 29823
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0
Sample Output

45
59
6
13
Source

Japan 2004 Domestic
原网页题目叙述.

代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int w,h;
char m[25][25];
int x0,y0;
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
int ans=0;

void dfs(int x, int y)
{
    int i,j;
    int x1,y1;
    for(i=0;i<4;i++)
    {
        x1=x+dx[i];
        y1=y+dy[i];
        if(m[x1][y1]=='.' && (x>0) && (x<=h) && (y>0) && (y<=w))
        {
         ans++;
         m[x1][y1]='#';
            dfs(x1, y1);
        }
    }
}

int main()
{
    int i,j;
    while(scanf("%d %d", &w, &h) && (w != 0))
    {
     getchar();
        ans=0;
        memset(m, 0, sizeof(m));
        for(i=1;i<=h;i++)
        {
            for(j=1;j<=w;j++)
            {
                scanf("%c", &m[i][j]);
                if(m[i][j]=='@')
                {
                    x0=i;
                    y0=j;
                    m[i][j]='#';
                }
            }
            getchar();
        }
        dfs(x0, y0);
        printf("%d\n", ans+1);
    }
}

反省

先放出AC前的代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int w,h;
char m[25][25];
int x0,y0;
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
int ans=0;

int dfs(int x, int y)
{
    int i,j;
    int x1,y1;
    for(i=0;i<4;i++)
    {
        x1=x+dx[i];
        y1=y+dy[i];
        if(m[x1][y1]=='.' && (x1>0) && (x1<=w) && (y1>0) && (y1<=h))
        {
            ans++;
            m[x1][y1]='#';
            dfs(x1, y1);
        }
    }
    return ans;
}

int main()
{
    int i,j;
    //scanf("%d %d", &w, &h);
    while(scanf("%d %d\n", &w, &h) && (w || h))
    {
        ans=0;
        for(i=1;i<=h;i++)
        {
            for(j=1;j<=w;j++)
            {
                scanf("%c", &m[i][j]);
                if(m[i][j]=='@')
                {
                    x0=i;
                    y0=j;
                }
            }
        }
        int sum=ans;
        printf("%d\n", sum);
    }

}

第一个问题就出在录入信息这环节,即不同颜色的矩阵表示,总是录入’\n’,这导致一开始i程序就出现问题。这种错误,在于基础的不扎实

第二个问题处在形如九宫格中只有中间那个是七点,其他都不能走的情况:

&&&
&@&
&&&

(用三个#不知道为什么无法显示)

这样的形式,一开始输出维0,其实应当输出1.
解决后就AC了。

菜是原罪

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值