kuangbin 专题二十二 区间DP(POJ 1651)Multiplication Puzzle

Multiplication Puzzle

Time limit1000 ms
Memory limit65536 kB
OSLinux

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10 ∗ 1 ∗ 50 + 50 ∗ 20 ∗ 5 + 10 ∗ 50 ∗ 5 = 500 + 5000 + 2500 = 8000 10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000 10150+50205+10505=500+5000+2500=8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1 ∗ 50 ∗ 20 + 1 ∗ 20 ∗ 5 + 10 ∗ 1 ∗ 5 = 1000 + 100 + 50 = 1150 1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150 15020+1205+1015=1000+100+50=1150.

  • Input
    The first line of the input contains the number of cards N ( 3 < = N < = 100 ) (3 <= N <= 100) (3<=N<=100). The second line contains N integers in the range from 1 to 100, separated by spaces.

  • Output
    Output must contain a single integer - the minimal score.

  • Sample Input
    6
    10 1 50 50 20 5

  • Sample Output
    3650

一道区间DP的题
题意就是 N 张卡牌,每拿掉一张 score 就加上 当 前 拿 掉 卡 牌 值 ∗ 左 边 未 拿 卡 牌 值 ∗ 右 边 未 拿 卡 牌 值 当前拿掉卡牌值*左边未拿卡牌值*右边未拿卡牌值 ,第一张和最后一张卡牌不动,拿到只剩那两张牌为止,求 score 的最小值
好像也是板子emmm,就分割成分割点左右的牌都拿了的情况

Time16ms
Memory148kB
Length798
LangC++
#include<cstdio>
#include<cstring>
#include <algorithm>

using namespace std;

int main() {
  int dp[105][105], a[105];
  int t, n;
  memset(dp, 0, sizeof(dp));
  memset(a, 0, sizeof(a));
  scanf("%d", &n);
  for (int i = 0; i < n; i++) scanf("%d", &a[i]);
  for (int i = 0; i < n; i++) {
    for (int j = i+1; j < n; j++) {
       dp[i][j] = 0x3f3f3f3f;//迫使每个区间都要跑一遍找最优解
    }
  }
  for(int d = 1; d <= n; d++) {//枚举长度
    for(int j = 1;j < n-d; j++) {//枚举起点
      int end = j + d;
      for(int i = j; i <= end; i++) {//枚举分割点,更新小区间最优解
        dp[j][end] = min(dp[j][end], dp[j][i] + dp[i+1][end] + a[j-1]*a[i]*a[end]);
        //分割点左边即j~i的牌都拿光了,右边i~end的牌也拿光了的情况,加上a[j-1]*a[i]*a[end]
      }
    }
  }
  printf("%d\n", dp[1][n-1]);
  return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值