Command Network POJ - 3164(最小树形图/朱刘算法)

Command Network POJ - 3164

题意:

1到所有点的最短距离,有向,最短,最小树形图(朱刘算法),板子题。没有任何坑点。
不会的点链接
学吧!
挺简单的。

注意:

别交G++,用C++交
原因如下:
在这里插入图片描述
  After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

  With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

  The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

  For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

代码:

#include <stdio.h>
#include <math.h>
int n, m;
double flag;
struct node {
    int be, en; double va;
}a[10010];
double zhuliu(int root) {
    int  pre[101], consume[101], vis[101], i;
    double sum = 0, dis[101];
    while (true) {
        for (i = 1; i <= n; i++)dis[i] = flag;
        for (i = 1; i <= m; i++)
            if (a[i].be != a[i].en && a[i].va < dis[a[i].en])
                pre[a[i].en] = a[i].be, dis[a[i].en] = a[i].va;
        for (i = 1; i <= n; i++) {
            if (i != root && dis[i] == flag)return -1;
            vis[i] = consume[i] = 0;
        }
        int cnt = 0;
        for (i = 1; i <= n; i++) {
            if (i == root)continue;
            sum += dis[i];
            int v = i;
            while (vis[v] != i && v != root && !consume[v])
                vis[v] = i, v = pre[v];
            if (!consume[v] && v != root) {
                consume[v] = ++cnt;
                for (int u = pre[v]; u != v; u = pre[u])
                    consume[u] = cnt;
            }
        }
        if (!cnt)return sum;
        for (i = 1; i <= n; i++)
            if (!consume[i])consume[i] = ++cnt;
        for (i = 1; i <= m; i++) {
            int u = a[i].be;
            int v = a[i].en;
            a[i].be = consume[u];
            a[i].en = consume[v];
            if (consume[u] != consume[v])a[i].va -= dis[v];
        }
        root = consume[root]; n = cnt;
    }
}
double calculate(double a, double b, double c, double d) {
    return sqrt((a - b) * (a - b) + (c - d) * (c - d));
}
int main() {
    while (~scanf("%d %d", &n, &m)) {
        double x[101], y[101]; flag = 1; int i;
        for (i = 1; i <= n; i++)scanf("%lf %lf", &x[i], &y[i]);
        for (i = 1; i <= m; i++) {
            scanf("%d %d", &a[i].be, &a[i].en);
            a[i].va = calculate(x[a[i].be], x[a[i].en], y[a[i].be], y[a[i].en]);
            flag += a[i].va;
        }
        double re = zhuliu(1);
        if (re == -1)printf("poor snoopy\n");
        else printf("%.2lf\n", re);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值