7-9 堆栈模拟队列 (25 分)

  设已知有两个堆栈S1和S2,请用这两个堆栈模拟出一个队列Q。

  所谓用堆栈模拟队列,实际上就是通过调用堆栈的下列操作函数:

  • int IsFull(Stack S):判断堆栈S是否已满,返回1或0;
  • int IsEmpty (Stack S ):判断堆栈S是否为空,返回1或0;
  • void Push(Stack S, ElementType item ):将元素item压入堆栈S;
  • ElementType Pop(Stack S ):删除并返回S的栈顶元素。
  • 实现队列的操作,即入队void AddQ(ElementType item) 和出队 ElementType
    DeleteQ()

输入格式:

  输入首先给出两个正整数N1和N2,表示堆栈S1和S2的最大容量。随后给出一系列的队列操作:A item表示将item入列(这里假设item为整型数字);D表示出队操作;T表示输入结束。

输出格式:

  对输入中的每个D操作,输出相应出队的数字,或者错误信息ERROR:Empty。如果入队操作无法执行,也需要输出ERROR:Full。每个输出占1行。

输入样例:

3 2
A 1 A 2 A 3 A 4 A 5 D A 6 D A 7 D A 8 D D D D T

输出样例:

ERROR:Full
1
ERROR:Full
2
3
4
7
8
ERROR:Empty

Code

#include<bits/stdc++.h>
#define ll long long
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);cout.tie(0);
using namespace std;
const ll MAXN = 1e12 + 10;
ll n, m, i, j, k, t, w, x, y, z, in, flag, cou, sum, maxn, minn;
string s, s1, s2;
const ll INF = 1e9 + 7;

int main()
{
    FAST_IO;
    cin >> n >> m;

    if ( n > m ) swap ( n, m );

    stack<ll>st1, st2;

    while ( cin >> s && s != "T" )
    {
        if ( s == "A" )
        {
            cin >> t;
            if ( st1.size() < n ) st1.push ( t );
            else if ( st2.empty() )
            {
                while ( !st1.empty() ) st2.push ( st1.top() ), st1.pop();
                st1.push(t);
            }
            else cout << "ERROR:Full" << endl;
        }
        else
        {
            if ( !st2.empty() ) cout << st2.top() << endl, st2.pop();
            else if ( !st1.empty() )
            {
                while ( !st1.empty() ) st2.push ( st1.top() ), st1.pop();

                cout << st2.top() << endl, st2.pop();

                while ( !st2.empty() ) st1.push ( st2.top() ), st2.pop();
            }
            else cout << "ERROR:Empty" << endl;
        }
    }

    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值