蓝桥杯练习【STL训练】——2010辽宁省决赛 SPY

题目描述:

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National 
Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two  List in the Commander’s hand, one is full of spies that Nation Y  will send to Nation X, and the other one is full of spies that Nation  X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier. So the commander decides to seize those that are sent by NationY, and   let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?
A:the list contains that will come to the NationX’s frontier.
B:the list contains spies that will be sent by Nation Y.
C:the list contains spies that were sent to NationY before.

输入:

There are several test cases. Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is  the number that NationX has sent to NationY before. 
The second part contains A strings, the name list of that will come  into the frontier. The second part contains B strings, the name list of that are sent by  NationY. The second part contains C strings, the name list of the “dual_spy”.   There will be a blank line after each test case. 
There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.

输出:

Output the list that the commander should caught (in the appearance     
order of the lists B).if no one should be caught, then , you should      
output “No enemy spy”

样例输入:

8 4 3 
Zhao Qian Sun Li Zhou Wu Zheng Wang 
Zhao Qian Sun Li 
Zhao Zhou Zheng 
2 2 2 
Zhao Qian 
Zhao Qian 
Zhao Qian

样例输出:

Qian Sun Li 
No enemy spy

解题思路:

用a,b,c分别存储A名单(入境C国的人)B名单(B国间谍)C名单(C国间谍)的人数,用三个数组arrayA[1005][100],arrayB[1005][100],arrayC[1005][100]存储各名单的人。自定义三个函数来判断A名单和C名单中是否有B名单中的人。若B名单的人在A名单中,且这个人不在C名单中,说明这个人既不是普通民众也不是双重间谍,故应逮捕。

参考代码:

#include<stdio.h>
#include<bits/stdc++.h>
using namespace std;
char arrayA[1005][100],arrayB[1005][100],arrayC[1005][100];
int a,b,c;
int checkA(int p){
    for(int i=0;i<a;i++){
        if(strcmp(arrayA[i],arrayB[p])==0)
        return 1;
    }
    return 0;
}
int checkC(int p){
    for(int i=0;i<c;i++){
        if(strcmp(arrayC[i],arrayB[p])==0)
        return 1;
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        for(int i=0;i<a;i++)
        scanf("%s",arrayA[i]);
        for(int i=0;i<b;i++)
        scanf("%s",arrayB[i]);
        for(int i=0;i<c;i++)
        scanf("%s",arrayC[i]);
        int flag=0;
        for(int i=0;i<b;i++)
        {
            if(checkC(i)==0 && checkA(i)==1 && flag==0)
            printf("%s",arrayB[i]),flag=1;
            else if(checkC(i)==0 && checkA(i)==1 && flag==1)
            printf(" %s",arrayB[i]);
        }
        if(flag==1)
        printf("\n");
        else
        printf("No enemy spy\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值