C++数据结构——层次遍历

层次遍历

给定二叉树的包含虚结点的先序遍历序列信息,按层次顺序给出遍历的结果。

输入格式:

首先输入一个整数T,表示测试数据的组数,然后是T组测试数据。每组测试数据在一行中输入一个字符串(不含空格且长度不超过80),表示二叉树的先序遍历序列(其中@表示虚结点)。

输出格式:

对于每组测试,输出层次遍历的结果。

输入样例:
1
ABD@@EG@@@C@F@@
输出样例:
ABCDEFG

代码长度限制 16 KB 时间限制 400 ms 内存限制 64 MB

解题代码

#include<bits/stdc++.h>
using namespace std;
int len;
string str;
template<class T>
struct treeNode{
	T data;
	treeNode *L_child,*R_child;
};


template<class T>
class Tree{
	public:
		~Tree(){
			this->root=new treeNode<T>();
			this->root->L_child=NULL;
			this->root->R_child=NULL;
		}
		treeNode<T>* createTree();
		treeNode<T>* getRoot();
	
	private:
		treeNode<T> *root;
};

template<class T>
treeNode<T>* Tree<T>::createTree()
{
	if(len>=str.size()) return NULL;
	T d = str[len++];
	if(d=='@'){
		return NULL;
	}
	treeNode<T> *node = new treeNode<T>();
	node->data=d;
	node->L_child=createTree();
	node->R_child=createTree();
	return node;
}

template<class T>
treeNode<T>* Tree<T>::getRoot()
{
	return this->root;
}

void levelFind(treeNode<char> *root){
	if(root==NULL) return;
	queue<treeNode<char>*> q;
	q.push(root);
	treeNode<char> *t;
	while(!q.empty()){
		t=q.front();
		if(t->L_child!=NULL){
			q.push(t->L_child);
		}
		if(t->R_child!=NULL){
			q.push(t->R_child);
		}
		cout<<t->data;
		q.pop();
	}
	cout<<endl;
}

int main()
{
	int n;
	cin>>n;
	while(n--){
		len=0;
		cin>>str;
		Tree<char> *tree = new Tree<char>();
		treeNode<char> *root = tree->getRoot();
		root = tree->createTree();
		levelFind(root);
	}
}

解题思路

这里我改了一下之前的代码,使用模板类,但是把结构体放到了外面,这样子方便使用,层次遍历需要用到队列去遍历,具体看https://zhuanlan.zhihu.com/p/107494578

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

祖安大龙

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值