问题 1433: [蓝桥杯][2013年第四届真题]危险系数
时间限制: 1Sec 内存限制: 128MB 提交: 1370 解决: 489
题目描述
问题描述
抗日战争时期,冀中平原的地道战曾发挥重要作用。
地道的多个站点间有通道连接,形成了庞大的网络。但也有隐患,当敌人发现了某个站点后,其它站点间可能因此会失去联系。
我们来定义一个危险系数DF(x,y):
对于两个站点x和y (x != y), 如果能找到一个站点z,当z被敌人破坏后,x和y不连通,那么我们称z为关于x,y的关键点。相应的,对于任意一对站点x和y,危险系数DF(x,y)就表示为这两点之间的关键点个数。
本题的任务是:已知网络结构,求两站点之间的危险系数。
输入
输入数据第一行包含2个整数n(2 < = n < = 1000), m(0 < = m < = 2000),分别代表站点数,通道数;
接下来m行,每行两个整数 u,v (1 < = u, v < = n; u != v)代表一条通道;
最后1行,两个数u,v,代表询问两点之间的危险系数DF(u, v)。
输出
一个整数,如果询问的两点不连通则输出-1.
样例输入
7 6
1 3
2 3
3 4
3 5
4 5
5 6
1 6
样例输出
2
分析:
dfs回溯
此题没有-1的输出,因为根据题意,所有点都是联通的。
代码:
package Test;
import java.util.Scanner;
public class test {
static int arr[][]; //地图
static boolean test[]; //判断站点是否走过
static int text[]; // 走过的站点
static int user[];//每个站点经过的次数
static int result = 0;//起点到终点的总路径数
static int n; //站点数
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
n = in.nextInt();
int m = in.nextInt();
arr = new int[n][n];
test = new boolean[n];
text = new int[n];
user = new int[n];
for (int i = 0; i < m; i++) {
int a = in.nextInt();
int b = in.nextInt();
arr[a-1][b-1] = arr[b-1][a-1]=1;
}
int x = in.nextInt();//起点
int y = in.nextInt();//终点
dfs(x-1,y-1,0);
int sum=0;
for (int i = 0; i < n; i++) {
if(user[i]==result){
sum++;
}
}
System.out.println(sum-2);//除开起始点和终点
}
private static void dfs(int x, int y, int temp) {
test[x] = true;//将走过的站点标记为真
text[temp] = x; //依次记录走过的站点
if(x==y){
result++; //路径条数+1
for (int i = 0; i <=temp; i++) { //将经过的站点取出来,次数+1
int s = text[i];
user[s]++;
}
}
for (int i = 0; i < n; i++) {
if(arr[x][i]==1 && test[i] ==false){ //找到想通的站点
dfs(i,y,temp+1);//前进
test[i]=false;//回溯
}
}
}
}