【python】PAT甲级1010 Radix (24/25分)

  1. 题目

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.
Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.
Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.
Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

  1. 代码
    测试点7不通过,运行超时了T_T。度娘后发现大佬用二分法解的题T_T,累觉无爱,改天再改吧,先放代码……
n1,n2,tag,radix=input().split()
if tag=="1":
    n=n1
    c=n2
else:
    n=n2
    c=n1

radix=int(radix)
#转换为10进制
if radix!=10:
    summ=0
    index=0
    while n:
        xx=n[-1]
        if xx.isdigit():
            xx=int(xx)
        else:
            xx=ord(xx)-87
        n=n[:-1]
        summ+=xx*radix**index
        index+=1
else:
    summ=int(n)
#最低进制为c中最大数值加1
e=max(list(c))
if e.isdigit():
    e=int(e)+1
else:
    e=ord(e)-86
ok=False
while 1:
    out=0
    index=0
    st=c
    while st:
        xx=st[-1]
        if xx.isdigit():
            xx=int(xx)
        else:
            xx=ord(xx)-87
            if e<=xx:
                e=xx+1
                ok=True
                break
        st=st[:-1]
        out+=xx*e**index
        index+=1
    if ok:
        ok=False
        continue
    if out==summ:
        print(e)
        break
    if out>summ:#进制越大化为10进制后的数越大
        print("Impossible")    
        break
    e+=1
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值