PTA甲级1046 Shortest Distance (20 分)

PTA甲级刷题记录
1046 Shortest Distance (20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
​5
​​ ]), followed by N integer distances D
​1
​​ D
​2
​​ ⋯ D
​N
​​ , where D
​i
​​ is the distance between the i-th and the (i+1)-st exits, and D
​N
​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
​4
​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

这个题目第三个用例超时,没想到可以直接计算"前缀和",然后用总的和减去直接计算的和就是另外一条路的长度,减去了一次循环的时间,得到了优化

超时代码

#include<bits/stdc++.h>
using namespace std;
int n,m;
int a,b;
long long c[100005];
int main(){
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>c[i];
	}
	cin>>m;
	long long sum;
	long long ans;
	for(int i=0;i<m;i++){
		ans = 0;
		sum = 0;
		cin>>a>>b;
		if(a>b){
			int t = a;
			a=b;
			b=t;
		}
		for(int i=a;i<b;i++){
			sum+=c[i];
		}
		ans = sum;
		sum = 0;
		for(int i=1;i<a;i++){
			if(sum>=ans){
				break;
			}
			sum+=c[i];
		}
		for(int i=b;i<=n;i++){
			if(sum>=ans){
				break;
			}
			sum+=c[i];
		}
		if(sum<ans){
			ans = sum;
		}
		cout<<ans<<endl;
	}
	return 0;
} 

正确代码

#include<bits/stdc++.h>
using namespace std;
int n,m;
int a,b;
long long c[100005];
int sum;
int main(){
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>a;
		sum+=a;
		c[i]=sum;
	}
	cin>>m;
	for(int i=0;i<m;i++){
		cin>>a>>b;
		if(a>b){
			int t=a;
			a=b;
			b=t;
		}
		int ans = c[b-1] - c[a-1];
		cout<<min(ans,sum-ans)<<endl;
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值