POJ -3253 Fence Repair

Fence Repair

Time Limit: 2000MSMemory Limit: 65536K

Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2…N+1: Each line contains a single integer describing the length of a needed plank
Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input
3
8
5
8

Sample Output
34

题意:切割一块木头的费用与其长度完全相同。FJ要锯开一块木头变成n块,现在给出n块木头的长度,问把这块木头切割成题目给出的长度,最少花费。

假如长度为6的木块切成1、2、3三个长度,最省钱的操作是先把6分为3、3,再把一个3分为1、2,共花费(1+2)+((1+2)+3)。所以当我们反推时,应先排序让小的跟小的合并,这样结果就是最小的。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
#include<vector>
using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        priority_queue<int, vector<int>, greater<int> > s;
        int t;
        for(int i=0; i<n; i++)
        {
            scanf("%d", &t);
            s.push(t);
        }
        int t1, t2;
        long long ans=0;
        if(s.size()==1)
        {
            ans+=s.top();
            s.pop();
        }
        while(s.size()>1)
        {
            t1=s.top(), s.pop();
            t2=s.top(), s.pop();
            ans+=t1+t2;//两个最小的合并
            s.push(t1+t2);
        }
        printf("%lld\n", ans);
        s.pop();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值