HDU -5672 String(尺取法)

String

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/65536 K (Java/Others)

Problem Description
There is a string S.S only contain lower case English character.(10≤length(S)≤1,000,000)
How many substrings there are that contain at least k(1≤k≤26) distinct characters?

Input
There are multiple test cases. The first line of input contains an integer T(1≤T≤10) indicating the number of test cases. For each test case:

The first line contains string S.
The second line contains a integer k(1≤k≤26).

Output
For each test case, output the number of substrings that contain at least k dictinct characters.

Sample Input
2
abcabcabca
4
abcabcabcabc
3

Sample Output
0
55

从前往后遍历,统计新出现的字母,若达到k个,则后面的再往上加都满足(ans+=l-r),然后去掉前i个字符看还有没有k个不同的字符,若有,加上相应的长度,若没有,继续往后遍历

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

char s[1000200];
int vis[30]={0};

int main()
{
    int t, k;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s%d", s, &k);
        int sum=0, len=strlen(s), r=0;
        long long ans=0;
        for(int i=0; i<len; i++)
        {
            while(sum<k&&r<len)
            {
                vis[s[r]-'a']++;
                if(vis[s[r]-'a']==1)//统计不同的字符
                    sum++;
                r++;
            }
            if(sum==k)//加上后面的长度
                ans+=len-r+1;
            vis[s[i]-'a']--;//去掉前i个字符
            if(vis[s[i]-'a']==0)//若这个字符是唯一的,sum--
                sum--;
        }
        printf("%lld\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值