Graveyard Design
Time Limit: 10000MS | Memory Limit: 64000K |
---|
Description
King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves.
After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.
Input
Input file contains n — the number of graves to be located in the graveyard (1 <= n <= 1014 ).
Output
On the first line of the output file print k — the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l — the number of sections in the corresponding graveyard, followed by l integers — the lengths of section sides (successive positive integer numbers). Output line’s in descending order of l.
Sample Input
2030
Sample Output
2
4 21 22 23 24
3 25 26 27
题意:输入一个n,找几个连续整数,他们的平方和为n,
输出长度及其方案。
21* 21+22* 22+23* 23+24* 24=2030,输出4和这四个数,
25* 25+26* 26+27* 27=2030,输出3和这三个数。
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;
#define ll __int64
int main()
{
ll n, s=0, l=1, r=0;//s为平方和
scanf("%lld", &n);
int a[2000][2], i=0;
ll m=sqrt(n*1.0);//大于根号n的肯定不满足条件,省去
while(1)
{
while(s<n)
{
r++;
s+=r*r;
}
if(r>m)
break;
if(s==n)
{
a[i][0]=l;//记录区间范围
a[i++][1]=r;
}
s-=(l*l);
l++;
}
printf("%d\n", i);
int j, k;
for(j=0; j<i; j++)
{
printf("%d", a[j][1]-a[j][0]+1);
for(k=a[j][0]; k<=a[j][1]; k++)
printf(" %d", k);
printf("\n");
}
return 0;
}