HDU -1595 find the longest of the shortest(Dijkstra,路径记录)

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input
5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output
11
13
27

题意:n个地方,m条路,这m条路中,有一条你不知道的路不能用,问在最坏的情况下,从1到n最短用时。
刚开始是循环模拟某一条路不能用,但是TLE,后来想了想,有的路根本不会去走,也就是删掉这条路,对最短时间无影响,所以我们只循环模拟那些会影响接最短时间的路,这里要对路径标记。
1、先Dijkstra一次,找到影响最小时间的路线并标记在pre[]中;
2、循环模拟,删除pre[]中的一条,再Dijkstra, 更新此时的最大值

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

const int N=1005;

int st, en;
int dist[N], map[N][N];
int pre[N];//pre[i]表示i与pre[i]连接
int n, m;

void dijkstra(int flag)//参数控制是否标记路径
{
    for(int i=1; i<=n; i++)
        dist[i]=INF;
    dist[st]=0;
    int vis[N]={0};//这里没有vis[st]=1
    int min, k;
    for(int i=1; i<n; i++)
    {
        min=INF;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&min>dist[j])
            {
                min=dist[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]>dist[k]+map[k][j])
            {
                dist[j]=dist[k]+map[k][j];
                if(flag==1)
                    pre[j]=k;
            }

    }
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        st=n, en=1;
        for(int i=1; i<=n; i++)
        {
            map[i][i]=0;
            for(int j=1; j<i; j++)
                map[i][j]=map[j][i]=INF;
        }
        int from, to, dic;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d", &from, &to, &dic);
            if(dic<map[from][to])
                map[from][to]=map[to][from]=dic;
        }//前面的都是必须的
        pre[st]=st;//起点连接的是自己
        dijkstra(1);//第一次要标记路径
        int maxx=dist[en];
        for(int i=en; i!=st; i=pre[i])
        {
            int t=map[i][pre[i]];
            map[i][pre[i]]=map[pre[i]][i]=INF;//i和pre[i]之间的路不能用
            dijkstra(0);//第一次之后就不标记路径了
            maxx=max(maxx, dist[en]);
            map[i][pre[i]]=map[pre[i]][i]=t;//记得复原
        }
        printf("%d\n", maxx);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
蛋白质耐热温度分类及预测重要数据表蛋白质是生物体中普遍存在的一类重要生物大分子,由天然氨基酸通过肽键连接而成。它具有复杂的分子结构和特定的生物功能,是表达生物遗传性状的一类主要物质。 蛋白质的结构可分为四级:一级结构是组成蛋白质多肽链的线性氨基酸序列;二级结构是依靠不同氨基酸之间的C=O和N-H基团间的氢键形成的稳定结构,主要为α螺旋和β折叠;三级结构是通过多个二级结构元素在三维空间的排列所形成的一个蛋白质分子的三维结构;四级结构用于描述由不同多肽链(亚基)间相互作用形成具有功能的蛋白质复合物分子。 蛋白质在生物体内具有多种功能,包括提供能量、维持电解质平衡、信息交流、构成人的身体以及免疫等。例如,蛋白质分解可以为人体提供能量,每克蛋白质能产生4千卡的热能;血液里的蛋白质能帮助维持体内的酸碱平衡和血液的渗透压;蛋白质是组成人体器官组织的重要物质,可以修复受损的器官功能,以及维持细胞的生长和更新;蛋白质也是构成多种生理活性的物质,如免疫球蛋白,具有维持机体正常免疫功能的作用。 蛋白质的合成是指生物按照从脱氧核糖核酸(DNA)转录得到的信使核糖核酸(mRNA)上的遗传信息合成蛋白质的过程。这个过程包括氨基酸的活化、多肽链合成的起始、肽链的延长、肽链的终止和释放以及蛋白质合成后的加工修饰等步骤。 蛋白质降解是指食物中的蛋白质经过蛋白质降解酶的作用降解为多肽和氨基酸然后被人体吸收的过程。这个过程在细胞的生理活动中发挥着极其重要的作用,例如将蛋白质降解后成为小分子的氨基酸,并被循环利用;处理错误折叠的蛋白质以及多余组分,使之降解,以防机体产生错误应答。 总的来说,蛋白质是生物体内不可或缺的一类重要物质,对于维持生物体的正常生理功能具有至关重要的作用。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值