HDU -1595 find the longest of the shortest(Dijkstra,路径记录)

find the longest of the shortest

Time Limit: 1000/5000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input
Each case there are two numbers in the first row, N and M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2. The cities are markedwith numbers from 1 to N, Mirko is located in city 1, and Marica in city N.
In the next M lines are three numbers A, B and V, separated by commas. 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000.Those numbers mean that there is a two-way road between cities A and B, and that it is crossable in V minutes.

Output
In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input
5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output
11
13
27

题意:n个地方,m条路,这m条路中,有一条你不知道的路不能用,问在最坏的情况下,从1到n最短用时。
刚开始是循环模拟某一条路不能用,但是TLE,后来想了想,有的路根本不会去走,也就是删掉这条路,对最短时间无影响,所以我们只循环模拟那些会影响接最短时间的路,这里要对路径标记。
1、先Dijkstra一次,找到影响最小时间的路线并标记在pre[]中;
2、循环模拟,删除pre[]中的一条,再Dijkstra, 更新此时的最大值

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

const int N=1005;

int st, en;
int dist[N], map[N][N];
int pre[N];//pre[i]表示i与pre[i]连接
int n, m;

void dijkstra(int flag)//参数控制是否标记路径
{
    for(int i=1; i<=n; i++)
        dist[i]=INF;
    dist[st]=0;
    int vis[N]={0};//这里没有vis[st]=1
    int min, k;
    for(int i=1; i<n; i++)
    {
        min=INF;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&min>dist[j])
            {
                min=dist[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1; j<=n; j++)
            if(!vis[j]&&dist[j]>dist[k]+map[k][j])
            {
                dist[j]=dist[k]+map[k][j];
                if(flag==1)
                    pre[j]=k;
            }

    }
}

int main()
{
    while(scanf("%d%d", &n, &m)!=EOF)
    {
        st=n, en=1;
        for(int i=1; i<=n; i++)
        {
            map[i][i]=0;
            for(int j=1; j<i; j++)
                map[i][j]=map[j][i]=INF;
        }
        int from, to, dic;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d", &from, &to, &dic);
            if(dic<map[from][to])
                map[from][to]=map[to][from]=dic;
        }//前面的都是必须的
        pre[st]=st;//起点连接的是自己
        dijkstra(1);//第一次要标记路径
        int maxx=dist[en];
        for(int i=en; i!=st; i=pre[i])
        {
            int t=map[i][pre[i]];
            map[i][pre[i]]=map[pre[i]][i]=INF;//i和pre[i]之间的路不能用
            dijkstra(0);//第一次之后就不标记路径了
            maxx=max(maxx, dist[en]);
            map[i][pre[i]]=map[pre[i]][i]=t;//记得复原
        }
        printf("%d\n", maxx);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值