POJ -1860 Currency Exchange(Bellman-Ford,判正环)

Currency Exchange

Time Limit: 1000MSMemory Limit: 30000K

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output
YES

题意:n种钱,m个兑换点,当前有s号钱币,价值是v。下面m行,6个数字分别表示a号钱币,b号钱币,a换成b的手续费和汇率,b换成a的手续费和汇率。问能不能经过几次兑换,使钱变多?

Tips:
负权回路:
在一个图里每条边都有一个权值(有正有负)
如果存在一个环(从某个点出发又回到自己的路径),而且这个环上所有权值之和是负数,那这就是一个负权环,也叫负权回路
存在负权回路的图是不能求两点间最短路的,因为只要在负权回路上不断兜圈子,所得的最短路长度可以任意小。
相反地,
正权回路:
如果存在一个环(从某个点出发又回到自己的路径),而且这个环上所有权值之和是正数,那这就是一个正权环,也叫正权回路
存在正权回路的图是不能求两点间最长路的,因为只要在正权回路上不断兜圈子,所得的最短路长度可以任意大。

在这里,a换成b就像是a镇到b镇,能换多少钱就是路程或者时间之类的,而且这是一个无向图,a可以到b,b也可以到a,现在问能不能经过几次兑换(移动),使钱(用时/路程)变多,这就符合正权回路的定义。

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
using namespace std;
typedef long long ll;
#define eps 1e-8
#define INF 0x3f3f3f3f
const int N=105;

struct date
{
    int a, b;
    double r, c;
};
date ee[N*2];

double dist[N];
int n, m, s;
double v;
int cnt;

int bellman_ford()
{
    for(int i=1;i<=n;i++)
        dist[i]=0;
    dist[s]=v;
    for(int j=1; j<n; j++)
    {
        int flag=0;
        for(int i=0; i<cnt; i++)
        {
            date e=ee[i];
            double temp=(dist[e.a]-e.c)*e.r;
            if(temp>dist[e.b])
            {
                dist[e.b]=temp;
                flag=1;
            }
        }
        if(flag==0)//本次循环没有再更新
            return 0;//没有正环回路
    }
    for(int i=0; i<cnt; i++)
    {
        date e=ee[i];
        double temp=(dist[e.a]-e.c)*e.r;
        if(temp>dist[e.b])
            return 1;//有正环回路
    }
    return 0;//没有正环回路
}

int main()
{
    while(scanf("%d%d%d%lf", &n, &m, &s, &v)!=EOF)
    {
        int a, b;
        double rab, rba, cab, cba;
        cnt=0;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&rab,&cab,&rba,&cba);
            ee[cnt].a=a, ee[cnt].b=b, ee[cnt].r=rab, ee[cnt].c=cab;
            cnt++;
            ee[cnt].a=b, ee[cnt].b=a, ee[cnt].r=rba, ee[cnt].c=cba;
            cnt++;
        }
        int ans=bellman_ford();
        if(ans)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值