poj--1976A Mini Locomotive(01背包)

A Mini Locomotive
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3826 Accepted: 2073
Description
A train has a locomotive that pulls the train with its many passenger coaches. If the locomotive breaks down, there is no way to pull the train. Therefore, the office of railroads decided to distribute three mini locomotives to each station. A mini locomotive can pull only a few passenger coaches. If a locomotive breaks down, three mini locomotives cannot pull all passenger coaches. So, the office of railroads made a decision as follows:

  1. Set the number of maximum passenger coaches a mini locomotive can pull, and a mini locomotive will not pull over the number. The number is same for all three locomotives.

  2. With three mini locomotives, let them transport the maximum number of passengers to destination. The office already knew the number of passengers in each passenger coach, and no passengers are allowed to move between coaches.

  3. Each mini locomotive pulls consecutive passenger coaches. Right after the locomotive, passenger coaches have numbers starting from 1.
    For example, assume there are 7 passenger coaches, and one mini locomotive can pull a maximum of 2 passenger coaches. The number of passengers in the passenger coaches, in order from 1 to 7, is 35, 40, 50, 10, 30, 45, and 60.
    If three mini locomotives pull passenger coaches 1-2, 3-4, and 6-7, they can transport 240 passengers. In this example, three mini locomotives cannot transport more than 240 passengers.
    Given the number of passenger coaches, the number of passengers in each passenger coach, and the maximum number of passenger coaches which can be pulled by a mini locomotive, write a program to find the maximum number of passengers which can be transported by the three mini locomotives.
    Input
    The first line of the input contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows:
    The first line of the input file contains the number of passenger coaches, which will not exceed 50,000. The second line contains a list of space separated integers giving the number of passengers in each coach, such that the ith number of in this line is the number of passengers in coach i. No coach holds more than 100 passengers. The third line contains the maximum number of passenger coaches which can be pulled by a single mini locomotive. This number will not exceed 1/3 of the number of passenger coaches.
    Output
    There should be one line per test case, containing the maximum number of passengers which can be transported by the three mini locomotives.
    Sample Input

    1
    7
    35 40 50 10 30 45 60
    2

Sample Output

240

题意描述;
有一列火车,现在有三辆火车头让你去拉火车车厢,而每一辆火车头可以拉m辆火车厢,问最多可以拉多少乘客,(每一辆火车头拉的火车车厢是连续的)
解题思路:
dp[i][j]表示前i个车厢用j个火车头去拉最多能拉的火车车厢的数量,因为算的时候在考虑第i个火车厢是否拉的时候要连带以i为第m个车厢的前m个车厢要一起拉,所以状态转移方程为:

dp[i][j]=max(dp[i-1][j],dp[i-m][j-1]+v[i]-v[i-m]);

要想达到最大的承载量意味着每一个车厢都要拉人,所以从3开始判断前i个车厢用3个车头去拉所能达到的最大值;
AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int dp[50001][4];
int w[50001],v[50001], n,m,t;
int  main()
{
	memset(dp,0,sizeof(dp));
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		for(int i=1; i<=n; i++)
		{
			scanf("%d", &w[i]);
			v[i]=v[i-1]+w[i];
		}
		scanf("%d", &m);
		for(int i=m; i<=n; i++)
		{
			for(int j=3; j>=1; j--)
			{
				dp[i][j]=max(dp[i-1][j],dp[i-m][j-1]+v[i]-v[i-m]);
				//选择第i个车厢连带前每个车厢一起拉,车头数减一,加上所拥有的承载量
				//还要减去前i-m个车厢所存储的承载量(因为选第i个车厢表示前面
				//会有一个车厢不再选择 
			}
		}
		printf("%d\n", dp[n][3]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值