POJ 1083 Moving Tables(贪心)

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.
在这里插入图片描述
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30
题意描述:
一层楼一共有400个房间,南北各有200个,从一个房间移动桌子到另一个房间,给出需要移动的房间桌子信息,并且无论移动多远都需要10分钟,移动时通道只能过一个,在互不影响的前提下可以多个同时移动,问完成所给任务,最少需要多少时间?
解题思路:
将每一段通道都进行依次标号,为1,2,,,,200;只需要将每一次经过的通道标号标记,最好将经过最多次的通道编号乘以10就好,需要注意的是在对移动桌子房间进行标记时,开始的一个应该是,(begin+1)/2,每一个加一除以二还是对应的通道号(自己可以模拟一下),最后找出经过次数最大的通道编号乘以10就好
Accept Code:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int num[203];
int main()
{
    int i,j,n,T,x,y;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%d",&n);
       memset(num,0,sizeof(num));
       for(i=0;i<n;i++)
       {
          scanf("%d %d",&x,&y);
          x=(x+1)/2;
          y=(y+1)/2;
          if(x>y)
          {int t=x;x=y;y=t;}
          for(j=x;j<=y;j++) 
          num[j]++;
       }
       sort(num,num+203);
       printf("%d\n",num[202]*10);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值