HDU1241Oil Deposits(DFS)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or @’, representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

题意:
只要连在一起的就算是一个油袋,并且连在一起具有连带性(只要有关联),检查所给地图一共有几个油袋?
解题思路:
用深搜从(0,0)去遍历每一个点,找到他附近的油,并把遍历到的油都变为*,以便于在以后的遍历中再次以已经遍历过得油为基点遍历;
Accept Code :

#include <stdio.h>
char map[102][102];
int n,m;
void dfs(int x,int y)
{
	int xx,yy;
	map[x][y]='*';
	for(xx=-1; xx<=1; xx++)
	{
		for(yy=-1; yy<=1; yy++)
		{
			int tx=x+xx;
			int ty=y+yy;
			if(tx>=0&&ty>=0&&tx<n&&ty<m&&map[tx][ty]=='@')
			   dfs(tx,ty);
		}
	}
	return ;
}
int main()
{
	while(scanf("%d %d", &n,&m)==2)
	{
		int step=0,i,j;
		if(m==0||n==0) break;
		for(i=0; i<n; i++)
			scanf("%s", map[i]);
		for(i=0; i<n; i++)
		{
			for(j=0; j<m; j++)
			{
				if(map[i][j]=='@')
				{
					 dfs(i,j);
				    step++;
				}	 
			}
		}
		printf("%d\n", step);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值