A Cubic number and A Cubic Number (HDU - 6216)

A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=273×3×3=27 so 2727 is a cubic number. The first few cubic numbers are 1,8,27,641,8,27,64 and 125125. Given an prime number pp. Check that if pp is a difference of two cubic numbers.
Input
The first of input contains an integer T (1≤T≤100)T (1≤T≤100) which is the total number of test cases.
For each test case, a line contains a prime number p (2≤p≤1012)p (2≤p≤1012).
Output
For each test case, output ‘YES’ if given pp is a difference of two cubic numbers, or ‘NO’ if not.
Sample Input
10
2
3
5
7
11
13
17
19
23
29
Sample Output
NO
NO
NO
YES
NO
NO
NO
YES
NO
NO
题意描述:
给出一个数检查一下这个数是不是两个数i(这两个数是aaa和bbb的形式)的差
解题思路:
因为差是一个素数所以这两个数即a,b是相邻的;
列出公式计算出a,b的值并且验证;
Accept Code:

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
//x^3-y^3=p因为立方差是素数所以x=y+1
//带入化简后是3y(y+1)+1=p 
int main()
{
	long long n,p,T;
	cin>>T;
	while(T--)
	{
		cin>>p;
		if((p-1)%3)
		printf("NO\n");
		else
		{
			n=(int)sqrt((p-1)/3);
			if(n*(n+1)==(p-1)/3)
			printf("YES\n");
			else
			printf("NO\n");
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值